[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances : noms vs versions de paquets



* Georges Mariano [12:15 17/08/03 CEST]:
Selon Sebastien Bacher <seb128@debian.org>:

Les paquets qui tournent sous 2.2 ne sont pas inutilisable, il suffit
juste de les rebuilder sur python2.3 ... ou s'il ne supportent pas
python2.3 les faire dépendre de python2.2 au lieu de python.

je profite d'avoir un pythoniste sous la main pour poser une question qui me
tracasse (également vraie pour d'autres ensembles de paquets)...

pourquoi avoir python2.1 python2.2 python2.4 et pas des python-*.* ?

On me corrigera si je dis des bêtises.

En fait, je pense que c'est du au fait que certains programme ne
fonctionne pas avec des versions récentes de python. Par exemple zope ne
fonctionne pas avec python2.2 (officiellement, en pratique je l'ai fait
tourner mais je ne pas chercher très loin pour voir où était les
incompatibilités).

De plus, comme il y a byte-compilation des .py, est-on sûre à chaque
fois qu'on passe d'une version à l'autre de python que le format est
compatible (je pense que oui mais je n'ai aucune certitude).

j'explique mon intuition actuelle de la chose ...

avec des python-*.* il existe un seul (sous)-graphe de dépendances relatifs à
python, avec des python*.* il existe autant de sous-graphes que de k1.k2 (2.1,
2.2, 2.3) car pour le système Debian, python2.1 et python2.2 n'ont rien à voir
entre-eux, sauf erreur et sauf meta-paquet qui établirait une relation.

Oui.

ce qui me gène le plus c'est que les concepteurs de python qui sont les seuls
habilités à déterminer ce qu'est une release python établissent un lien
_naturel_ entre les versions python (au sens 2.3 >= 2.2 >= 2.1), et que ce lien
est "naturellement" perdu par un packaging de la forme python*.*.

la question est donc : où ce lien est-il rétabli ?

En fait la Debian Python Policy indique que :

    At any given time, the package `python' will represent the current
    default Debian Python version.

    The default Debian Python version should alway be the latest stable
    upstream release that can be integrated in the distribution.
donc 'python' est le nom de l'interprêteur le plus actuel, cela ne
bougera pas tant quel la DPP ne sera pas modifiée.

autre formulation : je comprends pas en quoi jouer sur les _noms_ de paquets
permet de gérer "mieux"(?) les problèmes de version ?

Dépendre de "python" uniquement indique qu'un paquet est utilisable pour
toute les versions de python. Un paquet qui dépend de "python<X>.<Y>" ne
fonctionne que pour cette version là. Ainsi une dépendance sur une
version particulière n'empêche pas d'installer la nouvelle version de
python et donc de faire évoluer sa debian.

merci pour les éclaircissements

J'espère ne pas avoir dit trop de bêtises.

--
(°>  Nicolas Évrard
/ )  Liège - Belgique
^^

Attachment: pgpYpLIUH5G0I.pgp
Description: PGP signature


Reply to: