[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances : comportement étrange d'apt-get



Charles Plessy <charles@gizmotronics.dyndns.org> writes:

> Salut à tous,

Salut,


> gizmotronics:/# apt-get build-dep pybliographer
> Reading Package Lists...
> Building Dependency Tree...
> The following NEW packages will be installed:
>   autoconf autoconf2.13 automake1.4 autotools-dev binutils bonobo build-essential cpp cpp-3.3 debconf-utils debhelper
>   defoma dialog dpkg-dev esound-common file flex fontconfig g++ g++-3.3 gcc gcc-3.3 gconf gdk-imlib1 gdk-imlib1-dev
>   gettext gnome-bin gnome-libs-data gs gs-common gsfonts gtkglarea5 html2text imlib-base indent intltool-debian libart-dev
>   libart2 libaudiofile-dev libaudiofile0 libbonobo2 libbz2-1.0 libc6-dev libdb3-dev libdb4.0 libdb4.1 libefs1 libesd0
>   libesd0-dev libexpat1 libfontconfig1 libfreetype6 libgal23 libgconf11 libgdbm3 libgdk-pixbuf-gnome2 libgdk-pixbuf2
>   libgimpprint1 libglade-gnome0 libglade0 libglib1.2 libglib1.2-dev libglib2.0-0 libgnome-dev libgnome32 libgnomeprint-bin
>   libgnomeprint-data libgnomeprint15 libgnomesupport0 libgnomeui32 libgnorba-dev libgnorba27 libgnorbagtk0 libgtk1.2
>   libgtk1.2-common libgtk1.2-dev libgtkhtml20 libgtkxmhtml1 libjpeg62 libmagic1 liboaf0 liborbit-dev liborbit0 libpaper1
>   libpng10-0 libpng12-0 libpng2 libpopt-dev librecode-dev librecode0 libstdc++5-3.3-dev libtiff3g libtool libungif4g
>   libwrap0-dev libxml1 libzvt2 m4 make oaf patch perl perl-modules pkg-config po-debconf python python-dev
>   python-gdk-imlib python-gnome python-gtk python2.3 python2.3-dev recode sharutils xfree86-common xlibmesa3-gl
>   xlibmesa3-glu xlibs xlibs-data xlibs-dev zlib1g-dev
> 0 packages upgraded, 121 newly installed, 0 to remove and 0 not upgraded.
> Need to get 53.3MB of archives.
> After unpacking 178MB of additional disk space will be used.
> Do you want to continue? [Y/n] q
> Abort.
>
> Or, pour mémoire, pybliographer n'aime pas python2.3

Pourquoi il n'aime pas python2.3 ? Il a juste besoin d'être recompilé
pour python2.3 je pense.


> gizmotronics:/# apt-cache show pybliographer
> Package: pybliographer
> Priority: optional
> Section: gnome
> Installed-Size: 1126
> Maintainer: Chris Lawrence <lawrencc@debian.org>
> Architecture: i386
> Version: 1.0.11-12
> Depends: python (>= 2.2), python (<< 2.3), python-gdk-imlib, python-gnome (>= 1.4.4-2), libc6 (>= 2.3.1-1), libglib1.2 (>= 1.2.0), librecode0 (>= 3.6)
> Conflicts: librecode0 (<< 3.6-5)

Oui, il faut le recompiler pour python (>= 2.3), python (<<2.4)


> Alors pourquoi diable apt-get build-dep veut-il m'installer un python
> qui m'empèchera de compiler/installer pybliographer???

Parce que debian/control contient des build-depends qui ramène sur la
version courante de python ...


Une simple reconstruction du paquet pour python2.3 ne fonctionne pas ? 


Salutations,

Sebastien Bacher



Reply to: