[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances : comportement étrange d'apt-get



Charles Plessy <charles@gizmotronics.dyndns.org> writes:

> 	Faut-il comprendre que le changement de dépendance qui a cassé
> pybliographer a été provoqué mécaniquement sans intervention de son
> mainteneur? C'est à dire que quand Mr Debian_python décide de passer à
> la 2.3, les paquets qui tournent sous 2.2 deviennent inutilisables,
> même si en théorie ils peuvent tourner avec 2.3?

Oui, tous les paquets dépendants de python = python2.2 sont à
reconstruire pour python = python2.3, vue qu'on a changé la version par
defaut.

Les paquets qui tournent sous 2.2 ne sont pas inutilisable, il suffit
juste de les rebuilder sur python2.3 ... ou s'il ne supportent pas
python2.3 les faire dépendre de python2.2 au lieu de python.

La décision n'est pas uniquement prise par "Mr Debian_python" comme tu
le dis, mais collectivement ... on va pas rester éternellement à python
2.2 parce qu'on ne veut pas faire de transition non ?


> PS : Je vais peut-être jeter de l'huile sur le feu gratuitement, mais
> j'ai l'impression que sid passe de «on teste pour voir _si_ ça casse»
> à «on teste pour voir _ce qui_ casse». Cf les paquets inetutils*
> arrivés récemments dont au moins trois ne s'installent pas pour un
> conflit de manpage.

Rappel: le but premier de l'unstable est quand même de permettre les
changements et les transitions ... personne ne t'oblige à upgrader tous
les jours, tu peux attendre que la transition soit terminée.

Pour ton problème de inetutils* j'ai pas suivit, mais si les paquets on
un pb suffit de remplir un rapport de bug et d'attendre que ca soit
réglé.


Salutations,

Sebastien Bacher



Reply to: