[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances : comportement étrange d'apt-get



>> Oui, il faut le recompiler pour python (>= 2.3), python (<<2.4)
>
> Ben non, car voici le contenu de debian/control:
>
(...)
> Build-Depends: debhelper (>= 2.2.0), python-dev (>= 2.2), python-dev(<< 2.3),
>                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Oui, c'est bien ce que je disais, mettre à jour le paquet revient à
remplacer le >=2.2, <<2.3 par >=2.3, <<2.4


> C'est ce que j'essaye de faire, mais je n'y arrive pas. Si je
> magouille debian/control, c'est configure qui se plaint.

Oui, effectivement le configure pose problème. 

$ python   
Python 2.3+

Il a pas l'air d'aimer le "+" ...


Tu peux modifier le configure, autours de la ligne 1400:

base_version = string.split (sys.version) [0]

à remplacer par exemple par

base_version = string.split (sys.version, '+') [0]


Salutations,

Sebastien Bacher



Reply to: