[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install Debian 4.0 to watch DVD video

On 3/2/08, Adrian Levi <adrian.levi@gmail.com> wrote:
> On 02/03/2008, hce <webmail.hce@gmail.com> wrote:
> > I changed to "audo", it sitll does not work. But, if I start dhclient
>  >  manually, it works fine. I checked ps, there was a dhclient3 running.
>  >  Could that cause the problem? How can I config /etc/init.d to make the
>  >  dhclient running?
> dh-client is requiret to fetch a dhcp address for you, it should be running.
>  below is my /e/n/interfaces file
>  ===========================================
>  # This file describes the network interfaces available on your system
>  # and how to activate them. For more information, see interfaces(5).
>  # The loopback network interface
>  auto lo
>  iface lo inet loopback
>  # The primary network interface
>  auto eth0
>  iface eth0 inet dhcp
>  ===========================================
>  If you want to use dhcp make sure that it looks exactly like this.

Yes, my interfaces looks exactly like this.  And, it works if I run
the dhclient manually.

>  >  > AFAIK ssh depends on openssh-client and openssh-server so you should be
>  >  >  fine.
>  >
>  > The ssh client running fine. It can ssh to other linux box where the
>  >  sshd is running, but other linux box cannot ssh to it as there is no
>  >  sshd running on the Debian.
>  >
>  >  I searched Intenert find a ssh script and copied it to the
>  >  /etc/init.d. The instruction says to call "update-rc.d -f ssh defaults
>  >  20", then run "/etc/init.d/ssh start". But, I could not find
>  >  update-rc.d in my Debian box, is there alternative to make a runlevel
>  >  links manually for ssh defaults 20?
> Woo, slow down. Stop and think a minute. Debian is one of the easiest
>  and trouble free distributions to run, if a package is installed all
>  the required scripts are installed as well.
>  Have you tried running:
>  #/etc/init.d/ssh start
>  What did it return, was that script there to begin with? Did you check
>  to see if openssh-server is installed as Andrei suggested? The client
>  and server are in different packages. You may have the client
>  installed but not the server.
>  If you type in
>  starbuck:~# apt-get install openssh-server
>  You should get a response like below if the server is installed:
>  Reading package lists... Done
>  Building dependency tree... Done
>  openssh-server is already the newest version.
>  0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>  Attack one problem at a time and create a new thread in debian-user
>  for each new problem. Give us time to help you before trying things
>  that will make the end result harder to achieve or introduce new
>  faults.

Thanks Adrian, it works now after installing the openssh-server.

Thank you.

Kind Regards,


Reply to: