[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kein soundcore mehr nach wechsel von alsa auf oss



On 23.06.06 22:29:37, Andre Bischof wrote:
> Andreas Pakulat wrote:
> >Wann hatte ich behauptet das diese Meldung nicht
> >erscheinen wuerde? Ich habe nur davon gesprochen das dir ein apt-get
> >install <kernel-image-paket> deine menu.lst nicht abaendert, bzw. nicht
> >die von dir geaenderten Teile die nicht mit "AUTOMAGIC KERNELS LIST"
> >gekennzeichnet sind.
> 
> Ich will ja jetzt nicht korinthenkakerisch sein, aber ich zitiere mal aus der 
> Mail aus dem gleichen Thread vom 22.06., 20.23 Uhr, ziemlich weit unten:

Na wenn wir es genau nehmen dann aber bitte richtig genau...

> ich:
> > das Paket war ja noch da. Da kam dann eine Meldung wg. einer
> > > veralteten modules.dep, die neu gemacht werden müßte. Das könne schief
> > > laufen, daher solle man unbedingt danach neu booten, dann würde die
> > > richtig aufgebaut.  Gesagt, getan, dummerweise wurde die
> > > /boot/grub/menu.lst neu geschrieben,
> 
> du:
> Wer macht denn das bitte? Also dpkg-reconfigure sicher nicht.

Und das ist auch richtig so, dpkg-reconfigure tut das naemlich
tatsaechlich nicht. Der Schuldige ist update-grub (den man ueber einen
postinst_hook bzw. postrm_hook in /etc/kernel-img.conf beim
Installieren/Entfernen ausfuehren lassen kann). 

Ich habe aber von deiner Mail ein wenig zu viel abgeschnitten in diesem
Teil, denn was eigentlich niemand macht ist die menu.lst neu zu
schreiben und sich dabei ein root() "auszudenken". 

> >>oss müßte raus sein, alsa drin? Oder muss ich dafür noch zusätzlich was 
> >>machen?
> >OSS-Module sind immernoch da, sowohl die aus dem Kernel-Paket (falls
> >Debian OSS-Module aktiviert, was sie aber tun IIRC) als auch evtl.
> >welche aus deiner haendischen OSS-Installation. Aus der haendischen
> >Installation sind noch alle Module vorhanden die nicht im Kernelpaket
> >enthalten waren. Finden koenntest du die mit einem
> >cd /lib/modules/`uname -r`/
> >find -type f | while read f; do grep $f
> >/var/lib/dpkg/info/<paketname_vom_kernel_paket>.list >/dev/null 2>&1 ;
> >if test $? -ne 0; then echo $f; fi ; done
> >Das sucht alle Dateien im Kernel-Modul-Verzeichnis und prueft ob die
> >Datei in der Liste der vom Kernel-Paket installierten Dateien enthalten
> >ist (das grep). Wenn nicht ($? != 0) wird der Dateiname ausgegeben.
> >Alle dabei gemeldeten Dateien solltest du woanders hin verschieben (noch
> >nicht loeschen!, man weiss ja nie...).
> 
> root@linux:/lib/modules/2.6.12-1-386# find -type f | while read f; do grep $f \
> > /var/lib/dpkg/info/linux-image-2.6.12-1-386.list >/dev/null 2>&1 ; \
> > if test $? -ne 0; then echo $f; fi ; done
> ./kernel/drivers/misc/lirc_dev.ko
> ./kernel/drivers/misc/lirc_i2c.ko
> ./kernel/drivers/video/em8300_bak/adv717x.ko

Den Rest lass ich mal weg. Was davon zu NVidia bzw. deiner MPEG-Karte
gehoert weisst du ja sicher selbst. Ach und lirc hab ich auch schon
irgendwo mal gehoert...

> em8300 bzw. backups davon sind ja erstmal ok, lirc, kqemu und nvidia auch, 
> modules.ofmap sagt mir nix, aber sound-preoss.tar.bz2 klingt verdächtig, das 
> kick ich mal.

Moeglich dass dir die OSS-Installation da auch einfach mal alle
"vorhandenen" Sound-Module reingelegt hat und du dir diese ganze Odysee
mit einem tar -xjf haettest ersparen koennen ;-)

Andreas

-- 
You may be infinitely smaller than some things, but you're infinitely
larger than others.



Reply to: