[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to install custom package using defined dependency version

On Fri 26 May 2017 at 13:26:54 (-0500), Sijis Aviles wrote:
> On Fri, May 26, 2017 at 12:42 PM, David Wright <deblis@lionunicorn.co.uk>
> wrote:
> > Why not just copy the x.y.x version into the package name,
> > and then add 1 to allow for updates/corrections. That way,
> > you can even have both versions coexist.
> >
> > app-configs-1.0.5       1.0.5-1
> > app-configs-1.0.6       1.0.6-1
> >
> > à la
> >
> > cpp-4.7                 4.7.4-3
> > cpp-4.8                 4.8.4-1
> > cpp-4.9                 4.9.2-10
> >
> > and many other packages.
> >
> Thanks for the suggestion. I suppose we could change the versioning to
> app-configs-1.0.5-1 and so forth.

The package name will be app-configs-1.0.5
The version will be 1.0.5-1, with future revisions 1.0.5-2, 1.0.5-3 etc.
The file name will be app-configs-1.0.5_1.0.5-1.deb

> I would speculate though that I may still run into my original issue where
> I need my-app's control file to depend on a specific version of
> app-configs, even though there are multiple available versions (and likely
> higher versions) in the repository.

No. You've missed the point.

> Essentially I'm trying to get the following working:
> my-app-1.0.5 requires app-configs-1.0.5
> my-app-1.0.6 requires app-configs-1.0.6
> So when i type:
> $ apt-get install my-app=1.0.5 it installs app-configs-1.0.5.

No, you will type:

$ apt-get install my-app-1.0.5 and it will install app-configs-1.0.5,

$ apt-get install my-app-1.0.6 and it will install app-configs-1.0.6.

> Currently trying that I get the error:
> "my-app : Depends: app-configs (= 1.0-5~aaa) but 1.0-6~bbbb is to be
> installed."

Yes, you reported that. That's because you've made it depend on
"package app-configs version 1.0-5~aaa" and not "package app-configs-1.0.5".

> I want to make sure a speciflc my-app version installs only a specific
> app-configs version.

I don't know how to write it any clearer, so perhaps I should just
tell you to examine how your system deals with, eg,

cpp-4.8 and gcc-4.8,
python2.7-minimal and python2.7,
python3-minimal and python3,

Examine your /var/lib/dpkg/status file's "Package:" and "Depends:" lines.


Reply to: