[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to install custom package using defined dependency version

On Fri, May 26, 2017 at 12:42 PM, David Wright <deblis@lionunicorn.co.uk> wrote:
Why not just copy the x.y.x version into the package name,
and then add 1 to allow for updates/corrections. That way,
you can even have both versions coexist.

app-configs-1.0.5       1.0.5-1
app-configs-1.0.6       1.0.6-1

à la

cpp-4.7                 4.7.4-3
cpp-4.8                 4.8.4-1
cpp-4.9                 4.9.2-10

and many other packages.


Thanks for the suggestion. I suppose we could change the versioning to app-configs-1.0.5-1 and so forth.

I would speculate though that I may still run into my original issue where I need my-app's control file to depend on a specific version of app-configs, even though there are multiple available versions (and likely higher versions) in the repository.

Essentially I'm trying to get the following working:

my-app-1.0.5 requires app-configs-1.0.5
my-app-1.0.6 requires app-configs-1.0.6

So when i type:
$ apt-get install my-app=1.0.5 it installs app-configs-1.0.5.

Currently trying that I get the error:
"my-app : Depends: app-configs (= 1.0-5~aaa) but 1.0-6~bbbb is to be installed."

I want to make sure a speciflc my-app version installs only a specific app-configs version.


Reply to: