[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to install custom package using defined dependency version



On Fri 26 May 2017 at 10:02:20 (-0500), Sijis Aviles wrote:
> On Fri, May 26, 2017 at 9:16 AM, Frank <zuiderduin@gmx.com> wrote:
> >> If I understand what you say, only 1 version of app-configs should
> >> be available in the debian repo in order for this to work.
> > Simply put: in any particular repository the most recent version of the
> > dependency should be compatible with the most recent version of the main
> > package.
> In our case, the latest versions of each would be compatible.
> 
> I guess we are trying to basically pair my-app 1.0.5 with a app-configs
> 1.0.5 version and my-app 1.0.6 with a 1.0.6 app-config version, and so on.
> (The version will probably differ a bit and won't match exactly but you
> probably get the point).
> 
> In my ideal workflow, i would do the following (assume 1.0.6 is hte latest
> version)
> 
> $ apt-get install my-app
> This installs my-app 1.0.6 and app-configs 1.0.6
> 
> $apt-get install my-app=1.0.5
> This install my-app 1.0.5 and app-configs 1.0.5
> 
> I was trying to use the control file in an attempt to pair those packages
> together, which doesn't appear its possible.

Why not just copy the x.y.x version into the package name,
and then add 1 to allow for updates/corrections. That way,
you can even have both versions coexist.

app-configs-1.0.5	1.0.5-1
app-configs-1.0.6	1.0.6-1

à la

cpp-4.7			4.7.4-3
cpp-4.8			4.8.4-1
cpp-4.9			4.9.2-10

and many other packages.

Cheers,
David.


Reply to: