[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Oh no something has gone wrong! after reinstalling Debian and Gnome.



Thanks everyone for your responses. I did not expect such quick and full
response. I also really don't believe it has anything to do with
partitioning (Debian deleted the partitions and created exactly
corresponding partitions with guided partitioning). 
More info: When I installed initially with LXDE, I had horrible graphics
and no touchpad, upon installing the Linux-image from backports (4.9),
these problems were resolved. I have tried installing Linux-image 4.9
from backports (using the command line) now again, the problem persists.
However, in the debian-laptop users list, I guy who said he has the
exact same laptop (Asus X441SA) said he is running Gnome-Classic
(Gnome), I have tried asking him if he got this problem but have
received no response from him.
All commands outputs here are in a new installation (I have installed 3
times now), with the regular kernel (3.16)
Outputs:
inxi commands say 'command not found'
lspci .... :
00:02.0 VGA compatible controller [0300]: Intel Corporation Device
[8086:22b1] (rev 35)
Subsystem: ASUSTek Computer Inc. Device [1043:1290]
00:0b.0 Signa processing controller [1180]: Intel Corporation Device 
[8086:22dc] (rev 35)
Subsystem: ASUSTek Computer Inc. Device [1043:1290]
00:13.0 SATA Controller [0106]: Intel Corporation Device [8086:22a3]
(rev 35)

I have pasted Xorg log at https://paste.debian.net/933539

Should I just try Mate or XFCE?? is it possible that works?

thanks a lot,


On Sun, May 21, 2017, at 03:57 PM, Jimmy Johnson wrote:
> On 05/21/2017 12:52 PM, Michael Milliman wrote:
> >
> >
> > On 05/21/2017 12:23 PM, Jimmy Johnson wrote:
> 
> >>> However, the OP's post does not mention anything of this nature.  The OP
> >>> deleted the existing Debian partition(s) leaving the existing Windows
> >>> partition(s) alone.  No mention was made of the ordering of the
> >>> partitions on the drive.  The OP then re-installed Debian with the
> >>> Debian installer, effectively starting from scratch with Debian.
> >>> Everything seems to work, except GNOME is crashing on boot.  There are
> >>> several things that can cause this, and I have caused some of them on my
> >>> system before, however the fact that this is a fresh install limits the
> >>> possible causes, the most likely of them being a missing (non-free?)
> >>> video driver or some such required by GNOME to run properly.  The way
> >>> the OP went about scrapping and re-installing the Debian system is valid
> >>> and should not have caused a problem under normal circumstances.  Hence
> >>> the suspicion of a missing driver (again probably non-free, and likely
> >>> Radeon as well...I've had similar issues with my laptop).
> 
> >> I have a Lenovo laptop with the problem you describe and it's a
> >> kernel/video/plasma problem, works fine with the old Sid 4.7 kernel but
> >> not with the 4.9, first boot is ok, on restart you will not get the DM
> >> or x and may freeze up.  Sometimes switching back and forth on the
> >> consoles will get you x, alt+ctrl+F2-F1-F3-F7. Jessie back-ports are
> >> also 4.9 and don't work right too. The problem here is an
> >> Intel-965-mobile, I'm going to install the Jessie kernel and see if that
> >> works or maybe a Ubuntu kernel, I think they are 4.4 and 4.8, I know the
> >> 4.4 will work, for me anyways, but I have to do something cause the 4.7
> >> kernel is old now and not getting security updates.
> > Hey, its better than the 3.16 kernel I was stuck with for a long time up
> > until just a couple of months. :)  In my case, laptop would boot, but
> > the screen would be completely blanked out.  If I caught the boot
> > process at just the right time with a alt+ctl+F1, I could get it to
> > finish booting, if I missed the window, it was power-off, power-on!! :(
> > The first-boot on 3.16  would do usually boot into software emulation
> > mode, and then I installed the Radeon drivers, and everything was OK.  I
> > have 4.9 running now and working fine. Video drivers and wifi drivers
> > have been my bane for many a year!
> 
> I had to remove all Debian firmware and installed linux-image-generic 
> and linux-headers-generic and Ubuntu's firmware-linux, but now it's 
> running 4.4.0-21-generic, it's booting fine and I can get updates too. 
> So this kernel problem I've had for more than a year is fixed, I was 
> going to wait for Stretch to go final but I've waited long enough. This 
> was on two systems Sid/Testing and Stretch. The version I'm using is 
> Ubuntu 16.04, just in case the OP wants to try it, I used Synaptic to do 
> the work and pinned the Debian release so not to pickup any other Ubuntu 
> packages not needed and I was able to rid more than 800Mb of Debian 
> kernel's on each system.
> -- 
> Jimmy Johnson
> 
> Debian Sid/Testing - Plasma 5.8.6 - EXT4 at sda15
> Registered Linux User #380263
> 


Reply to: