[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: flashplayer9? (Mystery solved)



Andrew Sackville-West wrote:
On Sat, Dec 16, 2006 at 09:28:14AM -0800, Marc Shapiro wrote:
Angelina Carlton wrote:
W Paul Mills <Paul-NOT@Mills-USA.com> writes:
That is normal. updatedb does not go into user directories.
On my system, updatedb runs some time early in the morning, before 6am,
perhaps the OP's computer isn't on at that time?
This is getting even more confusing!

It certainly went into my user directories when I ran it manually, and I was thinking that you were correct and it was a timing thing. Those two checks were run on two successive days. I thought if I had just run the locate command again, since it was the next day, it would have found the files without having to run updatedb manually. But...

I just ran locate again this morning. It found all the file and symlinks in all the system directories that the install of flashplayer-nonfree placed there. It DID NOT find the files in my user directory, or in my wife's user directory tree. These are the places that it did find it yesterday after I manually ran updatedb. I ran updatedb MANUALLY this morning, and now it finds all copies of the file, in system AND user directories. Why would it find the files after a manual run of updatedb, and then lose them overnight?

Here is a copy of my /etc/updatedb.conf:

$ cat /etc/updatedb.conf
# This file sets environment variables which are used by updatedb

# Global options for invocations of find(1)
FINDOPTIONS='-ignore_readdir_race'
export FINDOPTIONS
# filesystems which are pruned from updatedb database
PRUNEFS="NFS nfs nfs4 afs binfmt_misc proc smbfs autofs iso9660 ncpfs coda devpts ftpfs devfs mfs shfs sysfs cifs lustre_lite tmpfs usbfs udf"
export PRUNEFS
# paths which are pruned from updatedb database
PRUNEPATHS="/tmp /usr/tmp /var/tmp /afs /amd /alex /var/spool /sfs /media"
export PRUNEPATHS
# netpaths which are added
NETPATHS=""
export NETPATHS
# run find as this user
LOCALUSER="nobody"
export LOCALUSER

I suspect this is the pertinent bit. per nam updatedb, $LOCALUSER
controls which user is used to search local directories. When the cron
job runs, it uses "nobody", when you run it, it runs as you. So you
(most likely) have read permissions on your local dirs, but I bet
"nobody" doesn't.
BINGO!!!

Both /home an ~/ have permissions of 755, giving read access to everyone (my wife and I are the only persons with physical access). However, ~/.mozilla has permissions of 700, no access to anyone but me!

Is it reasonable to let updatedb run as root, so that ALL directories would be included, or is this a Bad Idea (TM)?

--
Marc Shapiro
mshapiro_42@yahoo.com




Reply to: