[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: flashplayer9?

Wulfy wrote:
Kent West wrote:
You probably still have the ver7 .so in one of the plugins paths for Firefox. Do a "locate libflashplayer.so" and rename/move any that you aren't confident is the v.9 version out of any relevant plugins directories.
I used locate to find all the libflashplayer.so's. Most are symlinks to the /usr/lib/Mozilla/plugin directory where the real .so is.

On an aside, I tried a beta of 9; audio would often lock into a repeating stutter, but someone pointed me to a more recent beta, and most of the audio problems went away. But there were still enough irritations that I've gone back to 7, and when I come across a site that needs 9, more often than not, that site loses my eyeballs. Occasionally I'll quickly flip over to 9 (I just rename-swap the 7 and 9 versions of the file and restart FF).

I tried FF on a site[0] that worked with the v.7 plugin. The v.9 plugin was called (obviously as it's the only one on my system now) but there was no sound.

[0] http://www.wirral-mbc.gov.uk/Vikings/storyindex.shtml (all the scenes open into full page flash objects.)

I don't appear to have ANY version of flash currently installed --

$ aptitude search flash
p   flashplayer-mozilla             - Macromedia Flash Player
p   flashplugin-nonfree             - Adobe Flash Player plugin installer
p flashybrid - automates use of a flash disk as the root p libflash-dev - GPL Flash (SWF) Library - development file p libflash-mozplugin - GPL Flash (SWF) Library - Mozilla-compatib p libflash-swfplayer - GPL Flash (SWF) Library - stand-alone play p libflash0c2 - GPL Flash (SWF) Library - shared library p libroxen-flash2 - Flash2 module for the Roxen Challenger web p m16c-flash - Flash programmer for Renesas M16C and R8C p newsflash - gets news with the newnews command from a p vrflash - tool to flash kernels and romdisks to Agen


/$ locate libflashplayer.so

These are all on my Sarge partitions. The only plugin in /usr/local/lib/firefox/plugins is libnullplugin.so.

But the site above loads and plays. How, if I don't have any flashplayer installed? Does firefox 2.0 have some version of flash compiled in?

Marc Shapiro

Reply to: