[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing modem.

Hoyt Bailey wrote:
----- Original Message ----- From: "Kent West" <westk@acu.edu>

I tried minicom as I remember I reported the results the first time they
were the same this time.  I started KDE and selected the terminal read the
man page for minicom not much help there.  issued su and input the password.
input minicom -c, got 1/2 screen (top to bottom full 1/2 wide)with a colored
panel at the bottom. The only thing that worked was right clicking on the
items at the bottom (they showed menus that wouldnt do anything). Finally
reset and tryed again this time minicom -s and got the same 1/2 screen B/W
with options A thru F.  Typing a thru f resulted in going to that option on
screen. Changing the option had no effect. There was also a box below that I
couldnt get into that had some options including Exit. Could not do anything
except reset.

That doesn't sound like the minicom I just looked at, but then I'm running unstable.


Make sure that plug-n-pray is disabled in your bios as it can screw up

your settings.

Couldnt find an entry in BIOS for plug-n-pray or for plug-n-play either.
Isnt that a Windows function?

No; well, yes. Sort of. Not really. No. Definitely no.

It's a name popularized by Microsoft (perhaps invented by MS) that simply refers to the ability of the operating system (Windows in the case of MS) to set the hardware resources, such as COM ports and IRQ settings, etc, automagically for your various hardware. It was a much bigger deal in the days before PCI devices became popular. Nowadays the PCI subsystem takes care of PnP, for the most part. Still, many BIOSes have the option to turn the feature on or off. If the BIOS is told that there is a PnP OS, then the BIOS does just the minimal setup necessary and lets the OS do the rest. IF the BIOS is told that there is not a PnP OS, then the BIOS does all the hardware setup. It has been my experience that it's best to let the BIOS handle things, even if you have a Plug-n-Play-capable OS.

# cat /proc/pci

My system returned the following:
Bus 0, device 11, Function 0
Serial Controller: US Robotics/3Com 56K FaxModom Model 5610 (rev 1)
IRQ 19
Master capabile, latency=32
I/O at 0xd000 [0xd007]

With this info, I use the setserial

# setserial /dev/ttyS0 irq 5 port 0xc400 uart 16550a

----# setserial /dev/ttyS3 irq 19 port 0xd000 uart 16550a
bash: setserial command not found.
It would appear that there is a package I dont have installed.  Does anyone
know what the package would be?  Would that package also contain minicom?

They are separate packages. See "apt-cache show setserial" and "apt-cache show minicom".

I though setserial is part of the base OS and is installed automatically. I guess not.

Then I test the modem with the internet
connection wizard and it works.

?What is the internet connection wizard?

It's some utility in whatever distro he was using. For you, you'd use KPPP or pppconfig, etc.


Reply to: