[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What kernel module for "Sound Max Digital Audio"?

Andrea Vettorello wrote:

Kent West wrote:


So I ran through it again, this time with a "2> error.log" appended, and
this time putting in "100" on the three questions about frame size,etc.
Here's the contents of error.log:

touch: creating `/etc/alsa/modutils/0.5': No such file or directory
grep: /etc/alsa/modutils/0.5: No such file or directory
modprobe: Can't locate module snd
cat: /proc/asound/version: No such file or directory
expr: syntax error
modprobe: Can't locate module snd

You are very close. =) If i recall correctly, the first time i used alsaconf happened to me too...

Now, try "modprobe -l", you should find a module called something like "snd-card-intel_810.o". Now look in the first two line
of your /etc/modutils/alsa (it should be the symlink pointing to "/etc/alsa/modutils/0.5"): i think the second is something
like "alias snd-card-0 snd", try modifying in "alias snd-card-0 intel_810" (put the name of the module you have found using
modprobe), and restart alsa ("/etc/init.d/alsa restart"). Look in "/var/log/syslog" file for further error messages.


Wow! Very close! Again, I used dselect to remove any stuff having to do with alsa, and then started from scratch again, following the procedure outlined in earlier messages. However, one thing I noticed is that I had my MODULE_LOC environment variable set to /usr/src/local instead of to /usr/local/src. So I changed that this time around.

When I tried to install the alsa....deb, the system complained about a missing dependency (alsa-base, I believe). Hmm, must be a broken dependency . . . . So I installed that dependency.

This time the alsa....deb installed properly, and also this time the /etc/modutils/alsa link was created.

However the configuration of the alsa...deb it couldn't run alsaconf. Hmm, must not be a dependency. . . . So I installed alsaconf.

I didn't have to make the modification to the second line or so of /etc/modutils/alsa; it was already correct. However, I did have to run depmod and update-modules before alsaconf ran properly. But this time. . . .I actually got somewhere. alsaconf ran like it had been, but this time it didn't just stop and dump out errors, but offered to run alsa-mixer. This was something new to me that I had not seen before. Great-it looks like it might be working.

However, when I actually tried to play any sound, no sound came out of the speakers. I've tried both "saytime" and "splay [some .mp3 file]; both tests pause the cursor at the command prompt like the system is busy running a program, and then eventually returns like the program is finished running. I've double- and triple-checked the wiring. So either there's something about Gateway's implementation of this sound "card" that almost works in Linux but doesn't quite, or I've got some sort of hardware problem on this new machine, or I've still got some sort of esoteric software "thingy" holding me back.

Still, I'm MUCH farther along than I ever would have made it on my own, and almost exclusively thanks to Andrea! Thank you Andrea!

(Now, does this mean I'm going to have to temporarily move a Windows drive into the box to test the sound? Yuck!)

Reply to: