[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What kernel module for "Sound Max Digital Audio"?

Andrea Vettorello wrote:
> Kent West wrote:
> > >
> > >
> > > Kent West wrote:
> >
> > > <snip concerning Kent's inability to get sound out of AC'97/intel810 integrated sound on a Gateway E3400 using ALSA>
> >
> > Andrea replied:
> >
> > > You don't say if you added in the /etc/modutils the requested aliases for your sound
> > > card, mine where created quite correctly by alsaconf, but i remember well, in the
> > > sound card definition the name of my sound card was missing. I attach my alias file
> > > as example:
> > >
> > [...]
> > >
> > > In the list of your loaded module, i haven't found a snd-mixer entry, try looking in
> > > your syslog for some error, and as a last tip, look in /proc/asound to check the
> > > card status...
> > >
> >
> > This led me to another clue. There's nothing in /etc/modules.conf like
> > this. Nor is there anything like this in /etc/modutils/aliases. However,
> > the alsaconf program creates a file /etc/alsa/modutils/0.5 that has this
> > sort of info in it. But as far as I can tell, /etc/modules.conf is never
> > made aware of this file. I've tried running update-modules and depmod;
> > I've also tried modifying /etc/modutils/paths to contain the line
> > "/etc/alsa/modutils/0.5" and/or "/etc/alsa/modutils/", but then the
> > system complains about a bad line in /etc/modules.conf. I also noticed
> > that /etc/modutils/alsa-path was pointing to /lib/modules/'uname
> > -r'/alsa, whereas the actual modules are in /lib/modules/'uname
> > -r'/misc; I've changed /etc/modutils/alsa-path accordingly.
> I wasn't very clear, if you don't use alsaconf you should put (by hand) the correct aliases in /etc/modutils. I think you
> used alsaconf, so you should have found in your /etc/modutils a symbolic link called "alsa" that pointed to
> /etc/alsa/modutils/0.5; this is correct, when you launch the "update-modules" command, the /etc/modules.conf will be
> created merging the various alias files found in /etc/modutils...

When I run alsaconf, I get the following:
Loading driver:
Starting ALSA sound driver (version 0.9.0beta2): no sound cards defined.
Setting the PCM volume to 100% and the Master output volume to 50%
The ALSA sound driver was not detected in this system.
Could not initialize the mixer, the card was probably
not detected correctly.

Afterward, there is an /etc/modutils/alsa-path file, but no
/etc/modutils/alsa symlink. I can add that in by hand. But before I do
that, I'll follow your instructions below.

> About the change you made to the /etc/modutils/alsa-path, i think you don't used the "Debian way" (R) to compile the
> alsa-modules. = )
> To have a clean (an easy to maintain) installation, install the alsa-source package (in my system is version 0.5.10b-6),
> then untar the source you will find in /usr/src (/usr/src/alsa-driver.tar.gz) in wherever dir you choose (in your home,
> in /usr/local/src, wherever) and export with the environment variable MODULE_LOC the directory you choose (i put mine in
> /usr/local/src/modules/ so i use  "export MODULE_LOC=/usr/local/src/modules").
> Next cd into your kernel source tree, and issue the command "make-kpkg modules_image" (the real command i use is a little
> different i.e. something like this "fakeroot make-kpkg --revision=custom.1.0 modules_image", you will find all the
> details in the doc of "kernel-package" and "alsa-source")

Okay; I installed alsa-source. During the config phase it asked what
card I wanted to build; I told it "intel8x0". Then I moved
/usr/src/alsa-driver.tag.gz to /usr/local/src, and there untarred it,
which created /usr/local/src/modules/alsa-driver and put the files in

I then did an "export MODULE_LOC=/usr/local/src/modules" and did a "set"
to verify I typed it correctly. I then did "make-kpkg modules_image".

> At the end you should have a shiny new alsa modules package for your card ready to be installed.

Where? I have a /lib/modules/2.4.2/misc which has a bunch of modules,
but I expect, since the date-time stamp is three days old, that this is
from my previous manual attempt at compiling/installing the modules.

I still don't have an /etc/modutils/alsa symlink. Should I go ahead and
create this manually? While waiting for any response that anyone
provides (and thank you Andrea! you've been expecially helpful), I'll
try to clean out any remnants of my manual attempts at installing the
modules, and will then purge the alsa-source and try it again.

> > Maybe part of the problem is that dselect doesn't know about alsa
> > modules for a 2.4.2 kernel, only for 2.2.17 and 2.2.18, so I've
> > downloaded and compiled the modules and libs from the alsa site.
> I'm using 2.4.2 with alsa, so the problem lies probably with the configuration...
> Andrea

I'm really beginning to suspect that Gateway is shipping "win- sound
systems" on their motherboards. If this turns out to be the case, I'll
stop listing Gateway as a system that I feel good about to my

Reply to: