[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances et conflit (libpng-dev VS libpng2-dev)



Sven Luther wrote:

On Mon, Aug 18, 2003 at 11:56:38AM +0200, JusTiCe8 wrote:
lol mais tu n'est pas sous cet OS voyons, un reboot n'est pas indispensable ;)

Bof, je fais cela d'habitude dans le bios, comme j'eteint ma machine la
nuit, j'essayerai d'y penser demain matin. (En fait je suis un peu perdu
avec les differents paquet clock et date).

moi c'est les options de date qui me soule un peu, j'utilise linuxconf :).

Je voudrai à la fois avoir libqt3-dev et quelques autres dont celle ci dépend et libgtk2.0-dev, or la libqt3 depend aussi de libpng-dev et libgtk2.0 de libpng2-dev, toutes les 2 étant incompatibles. Or

Tu pourrait peut etre utiliser un backport du nouveau KDE/Qt. Cela
devrait te permettre d'installer qt avec libpng12-dev, ou quelque chose
du genre.
mouai... je suis un peu sceptique là.

libpng2-dev est censée fournir libpng-dev, mais cela ne suffit pas (pb quelque part ?) à satisfaire les dépendances.

Non, c'est pas comme cela que cela marche. les deux libs ne sont pas
compatibles, et il n'y a donc pas l'un qui fournit l'autre. au mieux,
libpng-dev est un wrapper pour la bonne version de libpng2 ou 3, mais
c'est tout.

ok.

Aussi, un apt-get install --no-remove libpng2-dev (juste pour voir) à quand meme besoin de supprimer les paquets en conflits et s'arrete en erreur, et un --download-only veut aussi supprimer ces paquets. Peut être devrai-je mettre une autre commande que install pour le deernier cas, mais je ne voit pas trop laquelle.

C'est normal, ces paquets sont incompatible, et il n'y a rien a faire a
part eliminer toutes les instances de l'un d'entre eux (de preference
libpng2/libpng10).
:/.

Amicalement,

Sven Luther

A+ et merci,

 J8.



Reply to: