[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances et conflit (libpng-dev VS libpng2-dev)



Bonjour,

Sven Luther wrote:

On Sun, Aug 17, 2003 at 10:36:33PM +0200, JusTiCe8 wrote:
euh... c'est moi ou mamadoo qu iavont un pb ou c'est toi ? tes msgs me parviennent du futur ! :)

Non, c'est moi, j'ai du faire une install windows xp pour recuperer les
images de la webcam/camera digital de ma belle-soeur, et cela a mis la
machine a l'heure non GMT, donc deux heures d'avances, il faut que je
pense a corriger cela la prochaine fois que je reboot.

lol mais tu n'est pas sous cet OS voyons, un reboot n'est pas indispensable ;)

cette diversité prolongée ne va t'elle à terme causer de grave pbs ?
En tout cas, certain(e)s continue de s'engouffrer dans la dangeureuse voie suivie depuis quelques temps déjà :(. <MODE JE VEUX PAS DEMARRER UN TROLL ON>N'auraient'ils/elles pas dû fusionner/utiliser 1 seul paquet une bonen fois pour toute ?<MODE JE VEUX PAS DEMARRER UN TROLL OFF>

Le probleme reel c'est qu'il faudrait utiliser la libpng12, qui est la
nouvelle version qui remplace la libpng10. Cependant, comme elle n'est
pas compatible avec l'ancienne, d'ou le changement de soname, il faut
modifier et/ou recompiler les anciens programmes qui dependent de
libpng10. Il ne s'agit pas de fusionner, juste avec le temps libpng10
doit disparaitre et libpng12 rester la seule nouvelle version, mais cela
ne se fait pas en un jour (ni en un ans d'ailleurs).

je vois.

Anciennement, et pour woody, aucune des deux libpng n'avait de soname,
ce qui fait qu'on ne pouvait pas les distinguer les unes des autres, et
donc l'installation des packages simultane (autant pour le package -dev
que pour le package tout court) causait probleme.

effectivement.

Malheureusement la solution a ce probleme est arrive apres la release de
woody, et il n'y a donc rien a faire, et meme un backport n'aide pas car
il faudrait alors recompiler tous les packages utilisant libpng, ce qui
est relativement lourd, et je conseille a ce moment de passer plutot a
sid.

Je veux bien le croire.
Passé en sid... je n'en ai pas envie, et comme cela ne fait rajouter qu'un petit soucis et une tache de plus dans mon "pipe", c'est pas si grave, au pire, tant pis pour les packages, je jouerai du tarball ;).

Quel est le probleme que tu a exactement ?
Je voudrai à la fois avoir libqt3-dev et quelques autres dont celle ci dépend et libgtk2.0-dev, or la libqt3 depend aussi de libpng-dev et libgtk2.0 de libpng2-dev, toutes les 2 étant incompatibles. Or libpng2-dev est censée fournir libpng-dev, mais cela ne suffit pas (pb quelque part ?) à satisfaire les dépendances.

Aussi, un apt-get install --no-remove libpng2-dev (juste pour voir) à quand meme besoin de supprimer les paquets en conflits et s'arrete en erreur, et un --download-only veut aussi supprimer ces paquets. Peut être devrai-je mettre une autre commande que install pour le deernier cas, mais je ne voit pas trop laquelle.

oui c'est bien le cas, je comprend mieux maintenant la problématique de ces lib et de leur multiples instances. Neammoins, je ne pense pas qu'une petite discussion-débat sur le sujet aurait menée au flameware kilométrique ;).

J'ai d'ailleurs essayer de te repondre. A voir donc.

Nous pouvons quand même papoter dans le calme lol.

Une flamewar n'a pas besoin d'etre agiter, c'est juste souvent une perte
de tempsi qui aurait pu etre plus productive, enfin ...
:) le temps est une richesse rare dont peu connaissent la valeur.

Sven Luther

A+,

 J8.



Reply to: