[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dépendances et conflit (libpng-dev VS libpng2-dev)



On Sun, Aug 17, 2003 at 08:53:13PM +0200, JusTiCe8 wrote:
> Sven Luther wrote:
> 
> >On Sun, Aug 17, 2003 at 12:47:13PM +0200, JusTiCe8 wrote:
> > 
> >
> >>Bonjour,
> >>
> >>je rencontre actuellement un petit pb de conflit entre paquet, comme 
> >>indiqué dans le titre. Sachant que libpng2-dev fourni libpng-dev mais 
> >>qu'un paquet dépend de libpng-dev et ne veux rien savoir (le vilain :) ) 
> >>et réclame absolument ce paquet alors que libpng2-dev le "fourni" (enfin 
> >>pas en tant que paquet au sens classique du terme utilisé avec Debian), 
> >>je me demande bien comment régler ce différent à l'amiable et sans trop 
> >>de heurts.
> >>   
> >>
> >
> >Tu est en woody, sarge ou sid ?
> >
> ouupps j'avais oublié de préciser :/ dsl., je suis en Woody.

Alors t'est mal barre pour ce probleme en particulier, mais bon, je suis
pas un expert de woody.

> >Les packages libpng-dev et libpng2/3-dev sont maintenant obsolet, et il
> >faut utiliser les nouveaux packages libpng10-dev et libpng12-dev, qui
> >s'installe parfaitement (en sid du moins, probablement en sarge aussi) :
> >
> >~$ dpkg -l | grep libpng
> >ii  imlib1         1.9.14-13      imaging library for X and X11 (using 
> >libpng2
> >ii  libpng10-0     1.0.15-4       PNG library, older version - runtime
> >ii  libpng10-dev   1.0.15-4       PNG library, older version - development
> >ii  libpng12-0     1.2.5.0-4      PNG library - runtime
> >ii  libpng12-dev   1.2.5.0-4      PNG library - development
> >ii  libpng2        1.0.15-4       PNG library, older version - runtime
> >ii  libpng3        1.2.5.0-4      PNG library - runtime
> >
> >A noter qu'il ne s'agissait pas uniquement d'un probleme de dependances
> >debian, libpng ne gerait pas les sonames correctement (ou n'en avait pas
> >du tout ou quelque chose du genre) ce qui a conduit a plusieurs annees
> >de recherche de solution a ce probleme, et de nombreux problemes de
> >compatibilite avec d'autres distribs, en particulier liee au linkage de
> >gnome 1 avec libpng3 et 2 par differentes distribs, pour ne citer que
> >le cas le plus fameux.
> >
> mmm... ben je vois que les réflexions ont menées à bien des sources de 
> pbs, autant de lib, c'est moyen.

En fait il n'y en a que deux, libpng2 et libpng3. La nouvelle version de
libpng2, portant le soname 1.0 ou quelque chose comme cela, est donc
appele nouvellement libpng10 et la libpng3, de soname 1.2, s'appelle
alors libpng12. Ceci permet d'avoir les librairies de developpement
installe simultanement, et il est possible grace au mechanisme des
sonames d'acceder a la bonne version sans problemes.

Anciennement, et pour woody, aucune des deux libpng n'avait de soname,
ce qui fait qu'on ne pouvait pas les distinguer les unes des autres, et
donc l'installation des packages simultane (autant pour le package -dev
que pour le package tout court) causait probleme.

Malheureusement la solution a ce probleme est arrive apres la release de
woody, et il n'y a donc rien a faire, et meme un backport n'aide pas car
il faudrait alors recompiler tous les packages utilisant libpng, ce qui
est relativement lourd, et je conseille a ce moment de passer plutot a
sid.


> Sinon, toi qui est DD, tu n'as pas répondu à mon intérrogation pas 
> forçément très explicite concernant ce genre de paquet qui en 
> fournissent d'autres, et dont les dépendances semblent ne pas refléter 
> ce fait.

Je t'avouerai que je n'ai pas tres bien compris ce que tu voulait, et
que je n'avait pas envie d'entrer dans une flamewar kilometrique que ce
genre de sujet a provoquer precedement, je me suis donc contenter
d'apporter une reponse informative (j'espere) sur le probleme des
libpngs.

Amicalement,

Sven Luther



Reply to: