[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: d-i on a second hard drive in a G5

On Mon, Feb 07, 2005 at 11:11:28AM -0500, Pedro Sanchez wrote:
> Well, some bad and some good news. Let's start with the bad ones:
> 1) I edited yaboot.conf to integrate the suggestions received so far
> (thank you!). Here is how it reads now. For the purposes of this e-mail
> I put double stars at the beginning of modified/added lines:
From what you write below (about being able to boot from OF directly) I
conclude that the path used there is the correct path to your second
hard disk. 
> boot=/dev/sdb2
> ** device=sd1:
I'm not sure why you set this to sd1:. If sd1: is not an alias to
/ht@0,f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0: this will not
> partition=3
> root=/dev/sdb3
> timeout=100
> install=/usr/lib/yaboot/yaboot
> magicboot=/usr/lib/yaboot/ofboot
> ** ofboot=/ht@0,f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0:2
To verify that this setting is correctly used while writing the boot
partition you can mount the bootstrap partition (while in linux) and
look at the ofboot.b file. It should contain a line like:
: bootyaboot " Loading second stage bootstrap..." .printf 100 ms load-base release-load-area " /ht@0,f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0:2,\\yaboot" $boot ;

> enablecdboot
> ** enableofboot
> macosx=/dev/sda3
> ** default=Linux
> image=/boot/vmlinux
>         label=Linux
>         read-only
>         initrd=/boot/initrd.img
> image=/boot/vmlinux.old
>         label=old
>         read-only
>         initrd=/boot/initrd.img.old
> I did the following while booting from the CD:
> 1. Mount all partitions. They are already initialized and loaded
>    from my previous install attempt.
> 2. Exit to a shell.
> 3. Edit /target/etc/yaboot.conf
> 4. chroot /target
> 5. mount -t proc none /proc
> 6. ybin -v
>    (everything looks OK from the ybin output, including
>     "Blessing /dev/sdb2 with Holy Penguin Pee")
> 7. Exit the shell, back to the installer's main menu.
> 8. Reboot the machine.
You could try to run ybin --debug to get some more debuging output.
> Nothing new. Still the "l" option in the text boot menu sends me back to
> the graphical boot menu. 
I think this indicates that something with the first stage OF Forth
script is still wrong. This script is in ofboot.b on your boot partition
and it is generated during the ybin/mkofboot call. The actual script
creating ofboot.b is /usr/lib/yaboot/ofboot. If you run ybin --debug you
will see the parameters that ybin uses to call this script.
> 2) The good news! I was able to boot Linux directly from the boot loader
> as suggested by Gaudenz and finish up the installation with Linux in the
> second hard drive. Once Linux was installed, I rebooted hoping that a
> miracle would give me Linux by default. No way, the machine booted
> automatically into OSX again. I tried then the graphical boot menu once
> more, and no way, graphical menu-->text menu-->"l" option-->graphical
> menu. I can't get out of this loop.
That means that the OF path to the boot partition is correct, but that
ybin does not set the correct boot device and that the first stage
script does not work as expected.

> So in conclusion, the only way to get into Linux now is via this long
> command at the OF prompt:
> boot /ht@0,f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0:2,\yaboot
> This loads Linux by default, as specified in the yaboot.conf file.
> So after all this exercise, who do you think is the bad guy here? I seem
> to conclude it is ofboot. Would you agree?
You probably mean ofpath? Yes I would say the same. Please file a bug on
the yaboot package with a reference to this thread!

Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~

Attachment: signature.asc
Description: Digital signature

Reply to: