[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Request for testing: /run and initscripts

On Fri, Apr 15, 2011 at 12:55:20PM +0200, Adam Borowski wrote:
> On Thu, Apr 14, 2011 at 08:19:38PM +0100, Roger Leigh wrote:
> > I think this should be fixed now; could you possibly try again
> > (you'll need a clean vserver environment that hasn't been upgraded
> > before).  The updated packages are at the same location as before.
> I've tried:
> * a copy of one that has seen no initscripts_2.88dsf-13.3 but was upgraded
>   since sarge
> * a freshly debootstrapped one
> Sadly, every time I get:
> fakerunlevel: open("/var/run/utmp"): No such file or directory

> guest environment detected: Migrating /var/run to /run
> guest environment detected: Migrating /var/lock to /run/lock
> guest environment detected: Not migrating in-use files in /dev/shm to /run/shm
> Processing triggers for man-db ...

This I really don't get.  There was no error reported, and we're using
this logic:

if [ ! -L /var/run ] && [ -d /var/run ]; then
    echo "guest environment detected: Migrating /var/run to /run"
    ( # Remove /run first, so all contents get moved
      rm -fr /run &&
      mv /var/run / &&
      ln -fs /run /var/run ) ||
      ( echo "Can't move /var/run to /run and replace with symlink; please fix manually."; exit 1 )

If the symlink creation failed, you should have got an error message.
I tested this in a chroot environment, and it worked fine.  Does anyone
have any clue?  Is the logic not right in the subshell or something?


  .''`.  Roger Leigh
 : :' :  Debian GNU/Linux             http://people.debian.org/~rleigh/
 `. `'   Printing on GNU/Linux?       http://gutenprint.sourceforge.net/
   `-    GPG Public Key: 0x25BFB848   Please GPG sign your mail.

Attachment: signature.asc
Description: Digital signature

Reply to: