[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Request for testing: /run and initscripts

On Wed, Apr 13, 2011 at 03:20:38PM +0200, Adam Borowski wrote:
> On Wed, Apr 13, 2011 at 01:49:15PM +0100, Roger Leigh wrote:
> > I have now implemented this (though it's not the default).
> > 
> > I would very much appreciate it if anyone could take the time to
> > install the new initscripts and test it out.
> > 
> > http://people.debian.org/~rleigh/run/sysvinit_2.88dsf-13.3.dsc
> > http://people.debian.org/~rleigh/run/initscripts_2.88dsf-13.3_amd64.deb
> It breaks down at least on vservers (which can't do mount() calls):
> find: `var/run': No such file or directory
> fakerunlevel: open("/var/run/utmp"): No such file or directory

I've now added support for vservers to the postinst (we treat
them like chroots, since they appear not to run rcS, which is
probably the root cause of the problems here).  The updated
packages are at the URIs above; could you possibly give it a
try and let me know if it works.

The same applies to lxc; if anyone uses it, I'd appreciate feedback.
I don't have any direct knowledge, so I am reliant upon users for
testing.  The same applies to GNU/Hurd.


  .''`.  Roger Leigh
 : :' :  Debian GNU/Linux             http://people.debian.org/~rleigh/
 `. `'   Printing on GNU/Linux?       http://gutenprint.sourceforge.net/
   `-    GPG Public Key: 0x25BFB848   Please GPG sign your mail.

Attachment: signature.asc
Description: Digital signature

Reply to: