[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SS4000E Fan speed, LEDS and power button


On Wed, Jul 18, 2012 at 01:33:44PM -0400, Chris Wilkinson wrote:

> Loaded the initrd.gz/zimage from daily images by ymodem and ran the exec
> with rescue/enable=true option. This runs d-i in rescue mode as you said.

Good point.

> Now when I get to the partitioning menu in d-i the option I select is
> 'assemble RAID array'. I don't think I want to select any of the existing
> partitions to use as a root file system.
> The next d-i menu list is 'automatic', followed by a list of existing
> partitions. I select 'automatic' and hit continue and it goes back to the
> previous step 'assemble RAID array', so I'm stuck in loop.
> So went back and tried selecting sda1 sdb1 sdc1 sdd1 as partitions to
> assemble but same result.

When creating the partitions, you have marked them as "Member of a
RAID set", right ? (Or something similar, perhaps "MD" ?, but you
should figure it easily in front of d-i)

If not, you should destroy any partition and redo the partitioning
from scratch, not omiting to mark each partition as "RAID set member".

The steps after is to assemble the corresponding RAID sets, and after
that to format the RAID sets themselves with you FS of choice.

(Until recently, you can also partition a RAID set, but I never played
with that feature.)

This can perhaps helps you :

lothar:~# cat /proc/mdstat 
Personalities : [raid1] [raid6] [raid5] [raid4] 
md2 : active raid5 sda3[0] sdd3[3] sdc3[2] sdb3[1]
      928886016 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]
md1 : active raid1 sda2[0] sdd2[3] sdc2[2] sdb2[1]
      497920 blocks [4/4] [UUUU]
md0 : active raid1 sda1[0] sdd1[3] sdc1[2] sdb1[1]
      2441728 blocks [4/4] [UUUU]
unused devices: <none>

lothar:~# df -h
Sys. de fichiers    Taille  Uti. Disp. Uti% Monté sur
/dev/md0              2,3G  597M  1,6G  27% /
tmpfs                 126M     0  126M   0% /lib/init/rw
udev                  124M  156K  123M   1% /dev
tmpfs                 126M     0  126M   0% /dev/shm
/dev/sde1             230G  119G  112G  52% /media/lacie
/dev/md2              872G  462G  411G  53% /srv

So, I've :

- md0 of 2.3 GB as / on a RAID1 set ;
- (md1 is swap, also RAID1 set) ;
- md2 of 872G as /srv on a RAID5 set.

You should take care to specify exactly the same size for the
corresponding RAID slices on each disk (see the sdX[1-3] up : every
member of a RAID set should have the same size. So here, for example,
sda1[0] sdd1[3] sdc1[2] sdb1[1] are all of the exact same size.)

IIRC, the d-i is able for now to do all the operations involved in
RAID creation, so it should work.

N.B. you can make your / smaller than mine for a NAS... I've seen to
big at setup time :-/




Reply to: