[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Further to my installation error

On Sun, 20 Mar 2016 12:51:56 +0100
Pascal Hambourg <pascal@plouf.fr.eu.org> wrote:

> Adam Wilson a écrit :
> > 
> > There is a potential problem also where modern machines (with UEFI
> > boot) fail to install off USB without UEFI, meaning that if you
> > want a UEFI-free install, you have to use optical media.  
> I have a rather old (~2007) UEFI motherboard which does the opposite :
> its UEFI firmware lacks USB and AHCI drivers so it is impossible to
> boot in UEFI mode from a USB device or from a SATA drive in AHCI mode.
> > This happened to me
> > on an ASUS UX51vz with UEFI- with Debian 7 d-i, inserting an optical
> > disc would provide the option to either boot the disk with UEFI or
> > without it,  
> Was this option displayed in the regular firmware boot menu or in a
> different menu ?

The boot order menu in the UEFI settings.

> > while inserting a USB would only allow UEFI boot from the
> > flash drive, and not legacy booting, even with Launch CSM enabled.  
> Do you mean the the firmware boot menu only displayed one option (EFI
> mode) for the USB device ?


> Did you try to boot a non-EFI capable USB boot media, such as a Debian
> live image or a Debian installation image with the EFI partition
> deleted ?

No. That did not occur to me; I assumed it would then refuse to boot at
all. I shall try this out and get back to you.

> > So while using Debian 7, I just had to use optical media to install
> > Debian sans UEFI (which I always do- call it nostalgia, but I like
> > the simplicity of MBR and four primary partitions rather than the
> > unfamiliar layers of GPT/UEFI related cruft).  
> Note that UEFI is not tied to GPT and vice versa. I happily use GPT on
> legacy systems when I need many partitions and LVM is not an option.
> Extended and logical partitions just suck.

And I don't like / don't need either GPT, LVM, or logical volumes! Four
primary partitions has always been enough for me.

> > Booting off USB (forced
> > to use UEFI) would simply result in a black screen after selecting
> > "Install".  
> I have seen this display problem with the EFI framebuffer driver in
> Wheezy's kernel on some machines. Installing with a serial console
> worked.

How does one do that?

> > Debian 8, however, seems to have solved this problem.  
> Indeed, the kernel EFI framebuffer driver in Jessie's driver seems to
> have been improved.

I wouldn't know anything about that, but from my field experience UEFI
works with far less hassle in Jessie as opposed to Wheezy.

> > USB can still
> > only be booted from UEFI, but newer d-i means that installation now
> > proceeds as normal until the point at which UEFI yes/no
> > (force/leave) selection is reached  
> I don't remember seeing this option in Jessie's installer when booted
> in EFI mode. How is it labeled exactly ? At what stage is it
> proposed ?

It isn't something I saw either until my first UEFI installation media
boot- it may have been triggered by the fact that I was using 'Launch
CSM' Legacy mode so that I wouldn't have to bother with GPT/UEFI and
could use something resembling traditional BIOS and MBR.

It is in between the tasksel stage and the GRUB installation stage. A
prompt appeared telling me that I could either 'Force UEFI' for the
operating system installation, and have Jessie configured to boot from
UEFI, or not. It detected the fact that I had booted from UEFI but my
system was capable of either booting method.

Attachment: pgpOAoQ57yMRm.pgp
Description: OpenPGP digital signature

Reply to: