[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Further to my installation error

Adam Wilson a écrit :
> There is a potential problem also where modern machines (with UEFI
> boot) fail to install off USB without UEFI, meaning that if you want a
> UEFI-free install, you have to use optical media.

I have a rather old (~2007) UEFI motherboard which does the opposite :
its UEFI firmware lacks USB and AHCI drivers so it is impossible to boot
in UEFI mode from a USB device or from a SATA drive in AHCI mode.

> This happened to me
> on an ASUS UX51vz with UEFI- with Debian 7 d-i, inserting an optical
> disc would provide the option to either boot the disk with UEFI or
> without it,

Was this option displayed in the regular firmware boot menu or in a
different menu ?

> while inserting a USB would only allow UEFI boot from the
> flash drive, and not legacy booting, even with Launch CSM enabled.

Do you mean the the firmware boot menu only displayed one option (EFI
mode) for the USB device ?

Did you try to boot a non-EFI capable USB boot media, such as a Debian
live image or a Debian installation image with the EFI partition
deleted ?

> So while using Debian 7, I just had to use optical media to install
> Debian sans UEFI (which I always do- call it nostalgia, but I like the
> simplicity of MBR and four primary partitions rather than the
> unfamiliar layers of GPT/UEFI related cruft).

Note that UEFI is not tied to GPT and vice versa. I happily use GPT on
legacy systems when I need many partitions and LVM is not an option.
Extended and logical partitions just suck.

> Booting off USB (forced
> to use UEFI) would simply result in a black screen after selecting
> "Install".

I have seen this display problem with the EFI framebuffer driver in
Wheezy's kernel on some machines. Installing with a serial console worked.

> Debian 8, however, seems to have solved this problem.

Indeed, the kernel EFI framebuffer driver in Jessie's driver seems to
have been improved.

> USB can still
> only be booted from UEFI, but newer d-i means that installation now
> proceeds as normal until the point at which UEFI yes/no (force/leave)
> selection is reached

I don't remember seeing this option in Jessie's installer when booted in
EFI mode. How is it labeled exactly ? At what stage is it proposed ?

Reply to: