[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gksu: Couldn't set environment variable...

On Mon, 05 Dec 2011 19:04:10 +0700, Sthu Deus wrote:

>>> $ /usr/bin/gksu -d -u usrname /usr/bin/chromium
>>                     ^^^^^^^^^^
>>That's not what I've asked for...
>>> $ /usr/bin/gksu -d -u usrname /usr/bin/qbittorrent
>>                     ^^^^^^^^^^
>>Neither this :-)
>>> As I have posted earlier. :o)
>>Nope. I wanted you to run those applications *as root*.
> OK. I thought You did mean that. My fault.
> But again, Camaleón, I would not to run those app.s w/ root privileges.
> May, You have any other idea? If not, then lets stop w/ this - for I
> suppose it to be risky. I know, You have another opinion on the matter.
> But let's have no controversy here on that.

There is no risk in running the commands I told you but I can't force you 
to do something you are afraid of (and I still dunno why because there is 
no technical nor logical reason for being so reluctant to do it but I 
can't do anymore to convince you).

We are trying to solve a problem with your current user's profile and 
having the result (regardless if it is success or not) of the same action 
run as root user can shed some light on this. But again, that's up to you 
and what's your real necessity of having the problem solved :-)

>>Hum... let's Google for the error. Look, some hits:
> Thanks for the links, though it seems not my case. - To be sure I have
> chown-ed whole the home dir. of the user and tried to start it - same
> error.

Did you already compare, side by side, your current user's .config folder 
and the other's user (from where the apps work)?

>>Uh? Whay are you so reluctant to make this test? Don't worry, you won't
>>be cracked by running the above command X-)
> Sorry, but no.


I would like to see a good reason for it but I'm not going to insist.



Reply to: