[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gksu: Couldn't set environment variable...

Thank You for Your time and answer, Camaleón:

>On Fri, 02 Dec 2011 17:46:36 +0700, Sthu Deus wrote:
>> Thank You for Your time and answer, Camaleón:
>>>So why don't you just run...
>>>gksu -d chromium
>>>gksu -d qbittorrent
>>>And tell us what happens? :-)
>> $ /usr/bin/gksu -d -u usrname /usr/bin/chromium 
>                     ^^^^^^^^^^
>That's not what I've asked for...
>> $ /usr/bin/gksu -d -u usrname /usr/bin/qbittorrent 
>                     ^^^^^^^^^^
>Neither this :-)
>> As I have posted earlier. :o)
>Nope. I wanted you to run those applications *as root*.

OK. I thought You did mean that. My fault.

But again, Camaleón, I would not to run those app.s w/ root privileges.
May, You have any other idea? If not, then lets stop w/ this - for I
suppose it to be risky. I know, You have another opinion on the matter.
But let's have no controversy here on that.

>>>Okay, run "ls -la .config/*/" so we can see what's in there...
>> Hmm, alright:
>There is no trace in there for Chromium nor Qbittorrent, maybe they
>are located in another folder under your user's path.
>>>Then find where are those applications storing the configuration
>>>data, it has to be somewhere under the user's profile.
>> That's the problem - it does not create any other dir.(s)...
>Hum... let's Google for the error. Look, some hits:

Thanks for the links, though it seems not my case. - To be sure I have
chown-ed whole the home dir. of the user and tried to start it - same

>Uh? Whay are you so reluctant to make this test? Don't worry, you
>won't be cracked by running the above command X-)

Sorry, but no.

>> Well. Please, do not waste too much of Your time on me - I gave my
>> question because I thought people use gksu a lot and easily would
>> guess what's wrong w/ my configuration, but turns out we are looking
>> for solution instead of correction of wrong configuration - so we
>> can end up here and will try to make a work around myself - for so
>> it seems me to be as the answer.
>Nah... You gave it up very quickly >:-P

Well, it turns to empty the user's dir. and then start fill it anew.
For because for ever existed user it does not work and for the newly
created it does, then it is ever existing problem related to programs
updates - when new system works better than the old one despite the
worked out configurations. :(

Reply to: