[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can you help me figure out why I can't get Grub to install from netinstall cd's?

For the last several days I have been attempting to install Wheezy from
one of the daily builds. I have tried four different builds (different
days)- and they all fail in the same two spots- they won't recognize my
removable medium (usb thumbdrive) so that I can install firmware, and,
more importantly, they fail to install Grub.

I have no problem doing an install from a Debian Squeeze install disc I
have (6.0.1a).

I am telling the install package to completely start fresh each time- new
partition table and reformatting the drive. Wouldn't that necessarily rule
out any existing problems with the hard drive (partition table, mbr,

I use the Graphical Expert Install option. I use the manual partition
option when I get to it. I delete all the existing partition then recreate
it. I have a 120GB SSD drive- I only partition one 40Gb primary partition
for the entire ext4 filesystem (mounted at / with bootable flag on) plus
one 6Gb swap file. The rest of the drive is left "free space". I would
think this to be a very simple setup and the same setup works fine if I
use the Squeeze install disc.

The install won't recognize my usb thumbdrive- this is exasperating but
minor compared to the Grub problem. Of course that means I have no
Internet connection, so no mirror use for install.

When I select the "Install the GRUB boot loader on a hard disk" menu
option I get this error:

"Grub installation failed. The 'grub-pc' package failed to install into
/target/. Without the GRUB boot loader, the installed system will not

I then go to a virtual terminal (Ctrl-Alt-F2) and look at /var/log/syslog.
Here are a few of the seemingly relevant lines from the last screen (not
all lines included here, but they are in proper sequential order):

"grub-installer: dpkg: warning: ignoring request to remove grub-legacy
which isn't installed."
"in-target: E: Package 'grub-pc' has no installation candidate."
"grub-installer: info: Calling 'apt-install grub-pc' failed"
"chroot: can't execute 'grub-probe': No such file or directory"
"File descriptor 4 (/dev/tty1) leaked on lvdisplay in vocation."
"Volume group "sda" not found."
"Skipping volume group sda."
"WARNING ***: Configuring 'grub-installer' failed."
"WARNING ***: Menu item 'grub-installer' failed"
"DEBUG: resolver (libgcc1): package doesn't exist (ignored)"
"DEBUG: resolver (libslang2-udeb): package doesn't exist (ignored)"
"INFO: Falling back to the package description for espeakup-udeb."

I can mount the usb drive (if I hadn't already) in order to save the debug
files. I can also mount the hard drive (sda1).

I can continue without the boot loader and I get the message "You will
need to boot manually with the /vmlinuz kernel on partition /dev/sda1 and
root=/dev/sda1 passed as a kernel argument." As an additional pain, I have
not found a way to do that (after hours of searching the web for help).
When I reboot I sometimes get the "grub rescue>" prompt- I haven't found
how to use that (help is not available and none of the web searches I run
find discussions relevant to Debian with this version of Grub, as opposed
to discussions of old Grub or Ubuntu LiveCD installs).

Actually, this last time I just got a blinking cursor in the top left
corner when I booted.

Evidently others are using these netinstall cd's with no problem (amd64).
I am new to Linux- this is really difficult for me to figure out. Can you

Here are the four netinstall cd's I have tried:

(Aug 22)

I can post the gzipped install debug files if anyone is willing to look at

I have several "rescue" discs, but nothing I have tried works to install
Grub properly (maybe because they have different versions of Grub?). I
have also tried Ubuntu boot-repair.

Keith Ostertag (keitho AT strucktower DOT com)
Lenovo Thinkpad T520, Intel graphics only, 4Gb ram, 120Gb SSD.

Reply to: