[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Fwd: Re: Getting connected to Verizon 3G network -UPDATE] {SOLVED}

Stan Hoeppner wrote:
Wayne <linuxtwo@gmail.com> put forth on 1/2/2010 1:53 PM:

As soon as you said firewall, I remembered having this problem before. I
had meant to disable the firewall last night when testing the MiFi
connection, but forgot.

First rule of thumb:  Network problem?  Disable all firewalls before additional

I did it just now and was able to ping, finally, 192.168.1 .1.  I then
http'ed to it and connected to the Admin page!!!  Entered the passwd and
got to the configuration pages.!!!  No firewall running but tried to
connect to Google anyway.  No Joy.  Checked /etc/resolv.conf. The DNS
from the MiFi are not there so replaced one with the mifi dns but no
joy.  I still think my routing is incomplete.

Can you ping any real addresses outside of 192.168.1.x?  Try  If
you can ping that then your only remaining issue is DNS resolution.  Try pinging
www.google.com.  Packet timeout and no DNS will return different errors.

Yes and I can connect to the internet with and without the firewall up. I have more to do on the firewall though. I can't connect to the MiFi admin page at with the firewall on. So, you are right on all points. Get the firewall working and 'then' fix everything else.

I checked the firewall script (firehol) and found an obvious error. As I
have been using modems I had  ehol) and found an obvious error. I've
been using modems so I had PUBLIC_MYIF="ppp+". Changed  it to
PUBLIC_MYIF="ath0", started the firewall, ran iptbles -S, tried to
connect, No, so ran iptables -F, tried to connect, no, do stopped the
firewall and connected to the admin page, but not to the internet.

I bet you have spent, and will spend, more time in your life screwing with
firewall problems on Linux desktop machines that you ever would fixing an
unfirewalled Linux machine that was compromised at the network layer, which is
the only thing packet firewalls prevent.  This scenario is true for the vast
majority of desktop Linux users:  packet firewalls cause more user problems than
they prevent.

I have seen that.  Not to long ago either.  I fixed it but can't
remember what I did. I 'think' it was due to an incorrect routing table
or the firewall though

You fixed it unknowingly by changing your iptables rules through firehol.

Do yourself a huge favor.  Once you get the dns/routing table issues fixed, turn
off packet firewalling, permanently, or learn to use it correctly.

I hope to be sending this through the 'firewalled' MiFi connection. We will see. I also have to get the resolvconfig package to fix the DNS addr's rather them keep doing it myself in resolv.conf.

Anyway, glad to hear you are a few steps closer to getting this all straightened

Stan, thanks to you for hanging on and getting me to check everything you could think of. If it had not been for you, I would have been f o r e v e r wondering what was up.

If you do not have a HAPPY and Prosperous New Year it sure will not be because you didn't stick to it.

My heart felt thanks for you for all of your help.

My BEST Regards to you and yours for the best year ever.


Reply to: