[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Fwd: Re: Getting connected to Verizon 3G network -UPDATE]

Stan Hoeppner wrote:
Wayne <linuxtwo@gmail.com> put forth on 12/31/2009 7:57 PM:

The following are the results of trying to connect to the MiFI
Output id from the wicd.log

2009/12/31 18:38:21 :: iwconfig ath0 channel 11
2009/12/31 18:38:21 :: iwconfig ath0 ap 00:21:E8:B5:C4:B5
2009/12/31 18:38:21 :: WPA_CLI RESULT IS DISCONNECTED
2009/12/31 18:38:22 :: WPA_CLI RESULT IS SCANNING
2009/12/31 18:38:23 :: WPA_CLI RESULT IS SCANNING
2009/12/31 18:38:24 :: WPA_CLI RESULT IS COMPLETED
2009/12/31 18:38:24 :: Running DHCP
2009/12/31 18:38:24 :: /sbin/dhclient ath0
2009/12/31 18:38:24 :: Internet Systems Consortium DHCP Client V3.1.3
2009/12/31 18:38:24 :: Copyright 2004-2009 Internet Systems Consortium.
2009/12/31 18:38:24 :: All rights reserved.
2009/12/31 18:38:24 :: For info, please visit
2009/12/31 18:38:24 ::
2009/12/31 18:38:24 :: wifi0: unknown hardware address type 801
2009/12/31 18:38:25 :: wifi0: unknown hardware address type 801
2009/12/31 18:38:25 :: Listening on LPF/ath0/00:26:5a:bb:e8:c5
2009/12/31 18:38:25 :: Sending on   LPF/ath0/00:26:5a:bb:e8:c5
2009/12/31 18:38:25 :: Sending on   Socket/fallback
2009/12/31 18:38:29 :: DHCPDISCOVER on ath0 to port 67
interval 8
2009/12/31 18:38:30 :: DHCPOFFER from
2009/12/31 18:38:30 :: DHCPREQUEST on ath0 to port 67
2009/12/31 18:38:30 :: DHCPACK from
2009/12/31 18:38:31 :: bound to -- renewal in 41564 seconds.
2009/12/31 18:38:31 :: DHCP connection successful
2009/12/31 18:38:31 :: Connecting thread exiting.
2009/12/31 18:38:31 :: IP Address is: None
2009/12/31 18:38:31 :: Sending connection attempt result Success

From the above it seems to be connecting to the MiFi, but wicd say's
not connected.

route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface   U     0      0        0
ath0         UG    0      0       ath0

Can not connect to, which 'should be' the admin page of the
MiFi or to the internet.

Define "connect".  This says you can't hit it via a browser on TCP 80.
Everything above says you received a valid DHCP assignment and should be able to
at least ping interface on the MiFi, unless an inbuilt firewall on
the MiFi 2200 blocks pings (very possible).

Can ping it for the connected XP on the laptop
Have you tried telneting
Yes & no joy there either
Have you run an nmap scan against to see if any ports
are open at all?

I had forgotten about nmap. No I dod not try it and I am in the process of trying to connect without network-managers. So can't try it now.

Most of these products are MS Windows centric (I'm talking the MiFi 2200 and
most consumer PC/network devices) and "leave the Linux nuts to figure it all out
on their own cause they're smart cause they run Linux" (so their thinking goes).
 My read of the very sparse information on their website eludes to the fact that
the device needs to be initially setup via a USB cable connected to a PC and
running the setup software on the CD that came in the product package.  I am
unable to get access to the actual user guide as their website has the file
username and password protected for some idiotic reason.  Have you performed the
setup yet of the MiFi 2200 exactly as described in the package documentation?
Does it require something stupid such as plugging in the MAC address of each
client you want to be able to use it or similar?

The unit did not come with what I would call a user manual. Of course it never mentioned linux and no it just said to setup the MiFi with a utility pgm while it was connected to a winbloz computer. After that it handles everything else. Did I mention that the MiFi OS is imbeded linux.(?)

You are able at this point to get a DHCP assignment from the MiFi 2200.  If your
Linux client (laptop/desktop) is unable to exchange packet traffic with the
MiFi, the problem at this point lies within the configuration of the MiFi
itself, not your Linux host.  You now need to read (or re-read) every ounce of
documentation you have or can find relating to the MiFi 2200.

The majority of the links I can find on the MiFi are all advertizing it.
The only posts I found about the MiFi and linux were posted by me. I informed the tier 2 support guys that now that Verizon has been advertizing for over a year that the USB760 Modem and the WiFi both work with linux, they should get off hteir butts and get some informatiom from the Novatel engineers to back up their claims. He just said, yea, they should. Even the Novatel site lacks and info or manuals.

I am not giving up!  My wife is surfing at 100-200 KBs and I am trying
hard to get this running while using a slow 2-20Kbs At&t GSM modem.
Verizion is the only option we have for a fast internet connection, darn it.

Thanks again Stan. I will keep reporting my attempts at getting this working. Maybe some Verizon people will get going on supporting what their advertizing claims their products can do.

Best Regards


I tried to bridge a winbloz box so that I could connect through it but
had no joy. I have an old 386 set up to be an AP and bridged it to our lan. Ran it for over a year till we got the ATT Modem. I have used Debian since '93 and know little about windows anymore.

Reply to: