[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: my new Inspiron - WAS: OT: laptop recomendations


> >
> Hi Micha, Hi to Everyone,
> Thanks for your help. I have not gone very far, in spite of much time 
> spent. I thought I ought to tell some details, especially since it might 
> help someone else, or, maybe, convince someone else to step in and tell 
> his/her own experience.
> At first, I have worked at my "sudo" problem on Ubunto. I briefly recall 
> what happened : after about one day, any call to "sudo ...", generated 
> the following reply :
> sudo: unable to resolve host dell-desktop

You need to set dell-desktop in /etc/hosts. Add a line	dell-desktop.local	dell-desktop

otherwise look in /etc/hosts to see what you machine expects  you hostname to
be. You can change the hostname to localhost by running hostname localhost

It's strange that it's not setup properly.

> So, I no longer had any possibility to intervene at tasks normally 
> acessible to root or superuser... except if this could be done in Gnome 
> environment, where my pasword still worked... but nothing accessible 
> from an Xterm. Sudo worked all right at the beginning, but it no longer 
> did. I spent a lot of time trying to overcome this, and, in the end, I 
> decided to try ... re-installing Ubuntu from the built-in installation 
> shell. Indeed, I have not felt sorry for having done so, since it was 
> very fast (less that 30 minutes or so, with no questions except in the 
> five last minutes). In the end, I got my system as it was a few days 
> ago, when unpacking. So the "sudo" fonction did work again... but not 
> for long ! This time, I know what I did just before it failed :
> Manual network configuration => General
> Host parameters
> Hostname : dell- desktop
> Domain name : blank space here
> Since I could not find a way to get my WiFi connexion working, I 
> wondered if I should write a domain name. On one of my other computers, 
> the domain name is "localdomain"... so, I wrote the same thing in the 
> blank space. Needless to say that this did not change anything in my 
> connections. But, ever since then, any call to "sudo", gave the same 
> answer as previously mentioned, that is :
> sudo: unable to resolve host dell-desktop
> Problem is that, once I removed that "domain name" from the host 
> parameters box,it did not change anything to my problem with sudo... I 
> maybe forced to re-re-install again ! But then, chances are great that 
> this bug or another one will force me to re-install quite often :) I 
> expect not to have to go through that once I have programs and data 
> installed on this system :(
> Now, as far as WiFi connexions are concerned, I spent a lot of time, 
> with absolutely no result or quite nearly so. Indeed, I have succeeded 
> in a real normal connection, with my Livebox set to "no encryption", and 
> after I disabled the MAC authentification. Then I set my machine to WEP 
> encryption, and then, after a thousand and one trials (well, maybe a 
> little less than that), I got ONE connexion ONCE, it was a real one 
> (82%), and workable one (I tried web pages using Hardy Heron 
> (Firefox)... but it did work no longer that 2 or 3 minutes, after that 
> time the icon stayed there and kept telling "82%", but I could no longer 
> access the web, and a "ping" resulted in "Network 
> Unreachable". I was unable to re-connect, even once. I haven't retried 
> WPA, since there are no reasons that it would work any better than before.

what is the output of ifconfig and iwconfig?

> Yes, I do have wpa_supplicant... but with no config file. In any case, 
> you should not need to fiddle with that on a system that is supposed to 
> be especially installed for that purpose ; you should be able to connect 
> out of the box. I recall that I can't go fiddling with 
> "/etc/network/interfaces" or launch "ifup wlan0", since sudo is not 

You don't need to play with it if you are using network-manager or wcid, if you
are trying to connect without something that sets wpa than you will need a
config file.

If you are using these you will need to make sure that the interfaces don't
appear in /etc/network/interfaces (which means that ifup wlan0 won't work

> accessible ; however, at the time when this was still possible, the 
> trials that I carried with "interfaces" did not lead to anywhere on this 
> system. In the meantime, so as to check if my Livebox was still 
> operating, I restarted my old Thinkpad 600 under Debian Lenny, and I 
> could wifi wep connect right away using ifup wlan0 ; the connection is 
> still up after more than one hour.

sounds like there is something wrong since from my experience ubuntu should
work out of the box with this (it will probably ask you to install the firmware
for the iwl3945 since it's in non-free though)

> Thanks in advance for more hints

Reply to: