[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: my new Inspiron - WAS: OT: laptop recomendations

Micha Feigin wrote:

On Thu, 08 Jan 2009 00:11:29 +0100
Bernard <bdebreil@teaser.fr> wrote:

Hi Chris, Hi to Everyone,

Stackpole, Chris wrote:

From: Bernard [mailto:bdebreil@teaser.fr]
Sent: Tuesday, January 06, 2009 4:44 PM
Subject: Re: my new Inspiron - WAS: OT: laptop recomendations

Stackpole, Chris wrote:
From: Bernard [mailto:bdebreil@teaser.fr]
Sent: Tuesday, January 06, 2009 2:41 PM
To: Stackpole, Chris
Subject: Re: my new Inspiron - WAS: OT: laptop recomendations

light did not came out and I got two networks available, one is my
neigbour's, the other one is mine. I gave the pasword as required,

it seems to reach a connexion... the former icon is being replaced

four bars... If I get the pointer on it, it says : "connection to
wireless network Livebox-46db (0%).


0% is bad; especially if you have 4 bars shown. Something isn't

Post your hardware please and let the list look at it.

Have fun!

my hardware is available at http://www.teaser.fr/~bdebreil/test.txt

I have managed to get a cable DSL connexion, just plugging the cable
from my desktop, and it worked right away, so that I have been able to
save the trouble of typing one line after the other. "ncftp" was easy
enough to install for the purpose of that transfer.

I just got the output of "lspci" at this stage.
Looking at your hardware I see this:
0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG
Network Connection (rev 02)

OK, I have that wireless card in one of my laptops. I know it works with
Ubuntu and Debian. If it is not working with your current setup,
something is buggered up.
I don't claim that it is not working, I just say that I haven't been able to get it to work as far as getting a connexion to my DSL router (Livebox). To this point, I'd rather suspect that I have not properly set up the parameters. I had a hell of a hard time to get it to work,

Any chance that you setup mac filtering on the router? Took me a couple of
hours of serious aggravation last time I tried to setup my wifes ipod touch ...

back a few month ago on my desktop with Debian Sarge. It is very complicated, to the point that, on that Desktop and Debian Sarge, I have only been able to get a WPA connexion on my DSL router box, not on places where I brought my computer (meeting rooms for associations), where it did work only under MSWIN. It worked easier with WEP encryption or no encryption. Therefore, I suspect that, if it does not work with my new DELL Inspiron under Ubuntu 8.04, it likely is because I have not properly setup parameters. Amongst most likely suspects, I would put :

It may be good to test wep and/or no encription as a start to make sure that
everything works and it's just an issue of setting up wep properly.

I found the wcid is better at handling wpa by the way that networkmanager which
keeps dropping the connection on me. Do you have wpa-supplicant installed?

- improper host (my hostname is supposed to be "dell-desktop" ; I don't know how I got this, it is "localhost" on my other computers

- improper way to send parameters to the system. For instance, under Debian Sarge on my desktop, my "interfaces" file include commands that shows passphrase under brackets, while the network manager on Ubuntu does not require brackets. There are a few details on my Interfaces file on Debian Sarge that I can't reproduce on Ubuntu, for instance the mode "Managed" and things of the kind. Such different ways to address parameters, is very confusing indeed ; it leads me to suspect that, as long as I have not found what is the problem, chances are rather slim that I get better results with Debian Lenny or SID. I bet that I would get a connexion right away if I changed the settings or my DSL Wifi to "no encryption", or to "WEP encryption", but I don't see the point of trying, since I don't intend to use any of these modes. What I did was testing that WPA wifi connexion still worked on my desktop : it does. On my new DELL laptop, no connexion works except cabled DSL connexion. However, as I said, the system works, since it detects neigbourhood wifi points, but can't connect. If you find it useful, I might try to convert my DSL wifi router to WEP encryption, but I bet it will work. Besides, I don't know how to overcome the fact that I can't use "sudo" : "unable to resolve host dell-desktop", which prevents me to modify the file /etc/network/interfaces. I must say, however, that the content of this file does change according to what I specify in the Ubunto/Gnome network interface, so this is a proof that it all works together. Indeed that "interfaces" file does look funny right now ; it includes a passphrase that I have never typed, and that is a lot longer than that I have typed. I must precise that, just in case you wouldn't have noticed, I am close to an ignorant as far as wifi config is concerned. At one time, amongst the so numerous options that were offered, I was proposed to type a "network pasword". I thought I had to type the WPA TKIP passphrase, so I did... but, two or three caracters before the end, no more was accepted... So it appears that I was supposed to type something else, or nothing at all. It maybe that my typings were translated into a passphrase, which can't be the right one... All this is so very confusing for a newbee...

Thanks for more help, on a more ground level basis.

Hi Micha, Hi to Everyone,

Thanks for your help. I have not gone very far, in spite of much time spent. I thought I ought to tell some details, especially since it might help someone else, or, maybe, convince someone else to step in and tell his/her own experience.

At first, I have worked at my "sudo" problem on Ubunto. I briefly recall what happened : after about one day, any call to "sudo ...", generated the following reply :

sudo: unable to resolve host dell-desktop

So, I no longer had any possibility to intervene at tasks normally acessible to root or superuser... except if this could be done in Gnome environment, where my pasword still worked... but nothing accessible from an Xterm. Sudo worked all right at the beginning, but it no longer did. I spent a lot of time trying to overcome this, and, in the end, I decided to try ... re-installing Ubuntu from the built-in installation shell. Indeed, I have not felt sorry for having done so, since it was very fast (less that 30 minutes or so, with no questions except in the five last minutes). In the end, I got my system as it was a few days ago, when unpacking. So the "sudo" fonction did work again... but not for long ! This time, I know what I did just before it failed :

Manual network configuration => General

Host parameters

Hostname : dell- desktop
Domain name : blank space here

Since I could not find a way to get my WiFi connexion working, I wondered if I should write a domain name. On one of my other computers, the domain name is "localdomain"... so, I wrote the same thing in the blank space. Needless to say that this did not change anything in my connections. But, ever since then, any call to "sudo", gave the same answer as previously mentioned, that is :

sudo: unable to resolve host dell-desktop

Problem is that, once I removed that "domain name" from the host parameters box,it did not change anything to my problem with sudo... I maybe forced to re-re-install again ! But then, chances are great that this bug or another one will force me to re-install quite often :) I expect not to have to go through that once I have programs and data installed on this system :(

Now, as far as WiFi connexions are concerned, I spent a lot of time, with absolutely no result or quite nearly so. Indeed, I have succeeded in a real normal connection, with my Livebox set to "no encryption", and after I disabled the MAC authentification. Then I set my machine to WEP encryption, and then, after a thousand and one trials (well, maybe a little less than that), I got ONE connexion ONCE, it was a real one (82%), and workable one (I tried web pages using Hardy Heron (Firefox)... but it did work no longer that 2 or 3 minutes, after that time the icon stayed there and kept telling "82%", but I could no longer access the web, and a "ping" resulted in "Network Unreachable". I was unable to re-connect, even once. I haven't retried WPA, since there are no reasons that it would work any better than before.

Yes, I do have wpa_supplicant... but with no config file. In any case, you should not need to fiddle with that on a system that is supposed to be especially installed for that purpose ; you should be able to connect out of the box. I recall that I can't go fiddling with "/etc/network/interfaces" or launch "ifup wlan0", since sudo is not accessible ; however, at the time when this was still possible, the trials that I carried with "interfaces" did not lead to anywhere on this system. In the meantime, so as to check if my Livebox was still operating, I restarted my old Thinkpad 600 under Debian Lenny, and I could wifi wep connect right away using ifup wlan0 ; the connection is still up after more than one hour.

Thanks in advance for more hints

Reply to: