[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: my new Inspiron - WAS: OT: laptop recomendations

Micha Feigin wrote:


Hi Micha, Hi to Everyone,

Thanks for your help. I have not gone very far, in spite of much time spent. I thought I ought to tell some details, especially since it might help someone else, or, maybe, convince someone else to step in and tell his/her own experience.

At first, I have worked at my "sudo" problem on Ubunto. I briefly recall what happened : after about one day, any call to "sudo ...", generated the following reply :

sudo: unable to resolve host dell-desktop

You need to set dell-desktop in /etc/hosts. Add a line	dell-desktop.local	dell-desktop

otherwise look in /etc/hosts to see what you machine expects  you hostname to
be. You can change the hostname to localhost by running hostname localhost

It's strange that it's not setup properly.

So, I no longer had any possibility to intervene at tasks normally acessible to root or superuser... except if this could be done in Gnome environment, where my pasword still worked... but nothing accessible from an Xterm. Sudo worked all right at the beginning, but it no longer did. I spent a lot of time trying to overcome this, and, in the end, I decided to try ... re-installing Ubuntu from the built-in installation shell. Indeed, I have not felt sorry for having done so, since it was very fast (less that 30 minutes or so, with no questions except in the five last minutes). In the end, I got my system as it was a few days ago, when unpacking. So the "sudo" fonction did work again... but not for long ! This time, I know what I did just before it failed :

Manual network configuration => General

Host parameters

Hostname : dell- desktop
Domain name : blank space here

Since I could not find a way to get my WiFi connexion working, I wondered if I should write a domain name. On one of my other computers, the domain name is "localdomain"... so, I wrote the same thing in the blank space. Needless to say that this did not change anything in my connections. But, ever since then, any call to "sudo", gave the same answer as previously mentioned, that is :

sudo: unable to resolve host dell-desktop

Problem is that, once I removed that "domain name" from the host parameters box,it did not change anything to my problem with sudo... I maybe forced to re-re-install again ! But then, chances are great that this bug or another one will force me to re-install quite often :) I expect not to have to go through that once I have programs and data installed on this system :(

Now, as far as WiFi connexions are concerned, I spent a lot of time, with absolutely no result or quite nearly so. Indeed, I have succeeded in a real normal connection, with my Livebox set to "no encryption", and after I disabled the MAC authentification. Then I set my machine to WEP encryption, and then, after a thousand and one trials (well, maybe a little less than that), I got ONE connexion ONCE, it was a real one (82%), and workable one (I tried web pages using Hardy Heron (Firefox)... but it did work no longer that 2 or 3 minutes, after that time the icon stayed there and kept telling "82%", but I could no longer access the web, and a "ping" resulted in "Network Unreachable". I was unable to re-connect, even once. I haven't retried WPA, since there are no reasons that it would work any better than before.

what is the output of ifconfig and iwconfig?

Yes, I do have wpa_supplicant... but with no config file. In any case, you should not need to fiddle with that on a system that is supposed to be especially installed for that purpose ; you should be able to connect out of the box. I recall that I can't go fiddling with "/etc/network/interfaces" or launch "ifup wlan0", since sudo is not

You don't need to play with it if you are using network-manager or wcid, if you
are trying to connect without something that sets wpa than you will need a
config file.

If you are using these you will need to make sure that the interfaces don't
appear in /etc/network/interfaces (which means that ifup wlan0 won't work

accessible ; however, at the time when this was still possible, the trials that I carried with "interfaces" did not lead to anywhere on this system. In the meantime, so as to check if my Livebox was still operating, I restarted my old Thinkpad 600 under Debian Lenny, and I could wifi wep connect right away using ifup wlan0 ; the connection is still up after more than one hour.

sounds like there is something wrong since from my experience ubuntu should
work out of the box with this (it will probably ask you to install the firmware
for the iwl3945 since it's in non-free though)

Thanks in advance for more hints

Thanks for your help. I have succeeded in overcoming my sudo problem, once I had added	dell-desktop.local	dell-desktop

in my /etc/host file. I had to add this from the recovery mode. Sudo now works.

As for WiFi... I am very confused, since it DOES work now, even though I can't tell why. Indeed, I was prepared to the worst. A Google search lead me to a person who stated that, ever since he had upgraded his Ubuntu to Hardy Heron,his wifi was out... He had been 19 days without, so he just bought cable extensions, he had gone through hundred of doc pages, tried a lot of things and nothing worked. Other people did reply to that forum, saying that the software iwl3945 did not work on Ubuntu 8.04, unless you de-install and reinstall, and even then... As for me, it was even better : iwl3945 was nowhere to be found on my system, and not available for install. I tried to modify my /etc/apt/sources.list so as to include "non-free", but it did not work (sudo apt-get update said it couldnt find those non-free). Later on, I learnt that, with Ubuntu, you can't access "non-free" unless you install a specific module for this. In any case, I was ready to quit and try something else, like installing Debian Etch or Lenny instead of Ubuntu, even if it was to take two weeks before the video was properly setup. So, as for my Livebox (my DSL modem router), I decided to reset it to "wpa" encryption, as it was before, since it did not operate even in WEP mode. Once this was done, and before I remove that DELL failure from my desk, I opted for a last trial. Right away I was prompted for the WPA passphrase, which I copied/pasted from a file. Almost right away, say, within four seconds, 4 bars replaced the turning laemurian. I couldn't believe it, and tried the pointer on it : 82% ! The connexion was sane and operative, and it did not quit after a while. At first, I did suppose that this was due to the fact that, at that specific time, my desktop PC was also wifi connected (while cable connected most other times), and I started to think that this might have helped. So, I disconnected that other connection and stop/start/stop/start my Ubuntu connection : it kept working at all times ! I went downstairs in other rooms, and, although the gain went down to 56% at one weird place, it still worked perfectly, and started all right after a stop. I just can't understand what happened. So, it now operates so neatly, even though I don't have the iwl3945 driver. From a cold stop, WPA wifi connection intervenes about 4 seconds after system boot. On my Desktop with Debian Sarge, using "ifup ra0", it takes longer than that, and I often have to retry several times before WiFi connection starts.
If it keeps working that way, I will then not bother installing another Debian distro, since there is no warranty that WPA WiFi will then work so smoothly. I don't like that Gnome environment, but I'll get used to, especially since this laptop is going to fulfill only maybe 5% of my needs, WiFi connections at congresses and seminaries or in hotels being most of that purpose.

Now that it seems to work, I must consider that this DELL Inspiron was not a bad bet for the price I paid. The "Ubuntu" OS does not seem so bad, even for a person who would not be familiar to computers.

Oh, by the way... Sound does not seem to work... even though the icon says that it is set to 80% volume... To be honest, I must admit that I don't really intend to use sound on that laptop... However, it would be nice to know that it worked :)

Thanks to everyone for your help


Reply to: