[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printing with lprng; no CUPS! :-)



On Fri, Jun 15, 2007 at 11:39:46AM +1000, CaT wrote:
> On Thu, Jun 14, 2007 at 05:51:00PM -0500, John Hasler wrote:
> > s. keeling wrote:
> > > (0) heretic /home/keeling_ aptitude -s install foomatic-gui
> > > ...
> > > The following packages will be automatically REMOVED:
> > >   lprng
> > 
> > toncho/~ sudo apt-get -s install foomatic-gui
> 
> Thank you. At least someone figured out that there was a reason why one
> might want to try apt-get instead. Aptitude, imo, tries too hard to err
> on the side of the completely clueless user.


Could some of that problem be having aptitude treat recommends as
required?

I only have a 26 year old dot-matrix printer; I use plain-old lpr.
On the box that still has a paralell port, I have a pretty full
text-mode environment plus minimal X (not all of xorg) and icewm.  On
that box, aptitude search '~i~dcups' shows nothing.

On my main box, I currently have no print spooler.  However, there is a
driver in the gs-esp package that will print postscript on my dot-matrix
printer.  That gs does require libcupsys2 and libcupsimage2; between the
two that's 565k uncompressed size.  Nothing else that I have installed
requires anything related to cups.

Doug.



Reply to: