[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [OT] Postfix - STARTTLS problem: 454 4.3.0 TLS not available due to local problem

On 5/18/07, Mihira Fernando <mihiratheace@gmail.com> wrote:
Deboo ^ wrote:

>> Does user postfix have access to the key file ?
> I chowned the postfix directory to user postfix and still it's the same
> thing.
Maybe you need to explicitly chmod/chown the key files to postfix user.
Worth givving a shot.
> Should I regenerate the keys?

If the above doesnt work, update both postfix and openssl and regenerate
the keys and try it. I remember seeing a bug in one version of openssl
that created a similar error for Postfix and the bug was fixed in an
updated version of openssl.

If TLS is switched off, does Postfix relay mail as it should ?

Yes postfix works normally without TLS. I have reinstalled postfix
after purging the package several times. At one time yesterday, apt
said postifx and all needed files were installed and when I go do a
/etc/init.d/postfix start, postfix said there was no postfix-script
under /etc/postfix/  ... and I saw that file wasn't there really.

I purged and reinstalled, that file is there now. But still,
reinstalling several times and regenerating the CA certs, I still ge
the same above error:

STARTTLS problem: 454 4.3.0 TLS not available due to local problem

And the postfix list doesn't care to respond it seems.

What is the way out? Building postfix from source? But what is the
guarante that I won't get this error then too. I have tried installing
postfix on Fedora and got the same error even on Fedora. How would I
know what the problem really is?

TLS in Postfix is messed up? I had nightmares getting it to work on
Sarge abo ut 3 years ago too I remember.

Please don't Cc: me, I'm subscribed to the list.

Reply to: