[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pppoe configuration - unable to ping outside

Now it's working,
Ok I tried found one difference between, my routing table on fedora
and debian
Fedora routing table
#route -n
Gives me Default gateway =

Whereas I found on debian Linux my Default gateway was not updated.
On Debian my Default gateway is not updated and it is
route -n
Default Gateway=

I tried this:
root@debian] route del default
root@debian] route add default gw

^ and I can access internet with my freshly installed Debian sarge 3.1 and pppoeconf
tool , I will look further to make it automatic,, currently didn't tried.. will give more details.
According to this, on my debian sarge3.1 routing table is not updating with pppoe.

Thank You for all your support, 
anugunj "anuj"
On Thu, 2006-12-28 at 12:19 +0000, richard@the-place.net wrote:
On Tue, Dec 26, 2006 at 11:25:07PM -0500, H.S. wrote:

> richard@the-place.net wrote:
> >On Tue, Dec 26, 2006 at 06:32:40PM +0100, Thilo Six wrote:
> >
> >
> >>Anuj Singh wrote the following on 25.12.2006 06:28:
> >>
> >><snip>
> >>
> >>>I have eth0 connected to my adsl router and eth1 to my local network.
> >>>I configured my adsl with pppoeconf, logs shows me I am connected, and
> >>>ifconfig gives me ppp0 address too.
> >>
> >>I you use a router to connect over dsl, this router will do the pppoe
> >>connection for you. On your computer you only have to activate dhcp
> >>(usually) or static ip via ethernet.
> >>
> >>remove the pppoe package completly (including startscripts + config)
> >>
> >><snip>
> >>
> >>computer --> via "normal" ethernet  -->  router -->  pppoe --> isp
> >
> >
> >That is definitely the easiest way, but I for one would like to know how
> >to do it the "difficult" way.  The easy road is not always open.
> >
> Then why are you connecting through the router? How about:
> ISP --> Eth0 -- Eth1 --> router --> home lan
>       '---computer---'

As I understood it, that is exactly what OP has.  I was interested
because his problem is similar to mine where I have

 ISP -->GPRSmodem--> usb -- Eth1 --> router --> home lan

(In that setup, I can only activate external or internal networking, but
not both at once.  The issue is I think my imperfect understanding of
routing, particularly how to achieve a different default route for
inward and outward traffic.  It is compounded by the fact that DHCP
rewrites resolv.conf, and pppd rewrites the routing table. Any
corrections I make are immediately overwritten.)


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: