[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sawfish - keybinding funny.

On Wed, Jun 04, 2003 at 12:52:46AM +1000, Richard Heycock wrote:
} On Tue, 2003-06-03 at 23:51, Gregory Seidman wrote:
} > On Tue, Jun 03, 2003 at 11:22:59PM +1000, Richard Heycock wrote:
} > } On Tue, 2003-06-03 at 21:15, Gregory Seidman wrote:
} > I have several shell commands bound to keys (e.g. xscreensaver-command
} > -lock), and they work fine. I have had some path issues on occasion, so try
} > giving the full path rather than just the command.
} Tried that. The same. To recapitulate. I've tried it:
} 	* not using a path
} 	* using the full path
} 	* using the inbuilt Xterm command.
} All the same. I don't even know how to go about debugging it. Having
} said that I just tried strace'ing sawfish and guess what it works every
} time. I hate stuff like this.
} So does this mean that it's not sawfish at fault, is it one of the
} libraries? Mutter, Mutter...
} Could you check that these are the same:

Other than the hex in parens, they are the same. I don't know what the hex
numbers signify but, with the exception of librep and /lib/ld-linux.so.2,
yours are all higher than mine. In fact, they are all higher by either
0x1000 or 0x3000. I have no idea what that signifies.

} I'm running out of ideas here.

I don't have any better ideas either, I'm afraid. Try apt-get install
--reinstall on sawfish and those various libraries?

} rgh

Reply to: