[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sawfish - keybinding funny.

On Tue, 2003-06-03 at 23:51, Gregory Seidman wrote:
> On Tue, Jun 03, 2003 at 11:22:59PM +1000, Richard Heycock wrote:
> } On Tue, 2003-06-03 at 21:15, Gregory Seidman wrote:
> [...]
> } > How odd. I'm using sawfish from testing (i.e. sarge, i.e. version 1:1.3-2)
> } > with GNOME2 and it works just fine. A version or two ago they broke the
> } > configuration tool (sawfish-ui), but it works now and it uses GTK2. My
> } > bound keystrokes work every time. GNOME2 has also gotten pretty solid and
> } 
> } It is only whn I run an external command (eg xterm, galeon) that cause a
> } problem. Internal commands (next work-space, shade etc) all work
> } perfectly.
> } 
> } Can you binding say Galeon to a key and see if it works for you?
> I have several shell commands bound to keys (e.g. xscreensaver-command
> -lock), and they work fine. I have had some path issues on occasion, so try
> giving the full path rather than just the command.

Tried that. The same. To recapitulate. I've tried it:

	* not using a path
	* using the full path
	* using the inbuilt Xterm command.

All the same. I don't even know how to go about debugging it. Having
said that I just tried strace'ing sawfish and guess what it works every
time. I hate stuff like this.

So does this mean that it's not sawfish at fault, is it one of the
libraries? Mutter, Mutter...

Could you check that these are the same:

        librep.so.9 => /usr/lib/librep.so.9 (0x40012000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x40070000)
        libgmp.so.3 => /usr/lib/libgmp.so.3 (0x4009d000)
        libgdk_pixbuf_xlib-2.0.so.0 =>
/usr/lib/libgdk_pixbuf_xlib-2.0.so.0 (0x400c5000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0
        libm.so.6 => /lib/libm.so.6 (0x400e5000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x40106000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x40136000)
        libdl.so.2 => /lib/libdl.so.2 (0x4013a000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x4013d000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x4019f000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x401a7000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x401bc000)
        libXft.so.2 => /usr/X11R6/lib/libXft.so.2 (0x40278000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40289000)
        libz.so.1 => /lib/libz.so.1 (0x402d9000)
        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x402e6000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x402ed000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40312000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x40320000)
        libc.so.6 => /lib/libc.so.6 (0x40333000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40443000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

I'm running out of ideas here.

> } > stable, and now that gaim is GTK2 everything I use plays nice together
> } > (well, okay, it can't remember anything about xterms and I refuse to use
> } > any other terminal emulator, but that's a personal problem).
> } 
> } How can you live without a terminal!?!?!?!?
> You misunderstand. I use xterm. I use many xterms. But I only use xterm.

Arrrr. I tried gnome-terminal for a while but I reverted back to xterm
(uxterm actually). 


> [...]
> } rgh
> --Greg
"It is possible to make things of great complexity out of things
 that are very simple. There is no conservation of simplicity"
 -- Stephen Wolfram

Richard Heycock <rgh@roughage.com.au>
key fingerprint : 909D CBFA C669 AC2F A937  AFA4 661B 9D21 EAAB 4291

Reply to: