[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re[2]: Debian testing system won't boot


Thanks for the suggestion, I loaded Morphix and can access the drive.
I ran fsck on the drive and it reported a meager 11060 errors, but
when I attempted a fsck --fix-fixable /dev/hda1 it would just output
the fsck version and do nothing.

Now that I can access the drive from Morphix, does anyone have any
suggestions on how to clean it up? I need actual commands as I'm by no
means a Linux expert, just a relatively inexperienced user.

Here's a recap of the problem:

SA> I came in today and found my Debian test server (2.2.17-reiserfs) to
SA> be down, so I rebooted and now it won't fully boot.
SA> It stops booting after the lines:
SA> "
SA> PPP: version 2.3.7 (demand dialling)
SA> PPP line discipline registered.
SA> "
SA> The thing is I don't need PPP; I don't even have a modem installed on
SA> the machine. Here are some other messages I found that might be
SA> important.
SA> "
SA> ReiserFS version 3.5.28
SA> VFS: Mounted root (reiserfs filesystem) readonly.
SA> Freeing unused kernel memory: 128k freed
SA> INIT: version 2.84 booting
SA> Loading /etc/console/boottime.kmap.gz
SA> Activating swap.
SA> Adding Swap: 144544k swap-space (priority -1)
SA> insmod: insmod: a module named af_packet already exists
SA> insmod: insmod: insmod net-pf-17 failed
SA> uname uses obsolete (PF_INET,SOCK_PACKET)
SA> device eth0 entered promiscuous mode
SA> CSLIP: code copyright 1989 Regents of the University of California
SA> PPP: version 2.3.7 (demand dialling)
SA> PPP line discipline registered.
SA> "
SA> then nothing.

which turned into:

SA> Ok. So I went through init.d and discovered the system reaches a
SA> prompt after I removed, rcS, which runs everything in /etc/rcS.d
SA> So I went into emergency mode and logged in as root, and manually ./
SA> each file in /etc/rcS.d to see if I could recreate the error, nothing
SA> produced an error. I "exit" from being root, and then it executes the
SA> rest of init.d and then takes me to a normal login prompt. I enter
SA> my username, hit enter, and then the message "XD: Loaded as module"
SA> pops up, I enter my pw and it displays the default "welcome" text, but
SA> then immediately kicks me back out to the login prompt.
SA> I reboot and it takes me to an emergency prompt like login, without me
SA> doing anything. I try to login and it boots me back out immediately to
SA> a login prompt. I reboot again and this time engage emergency mode,
SA> and it again prompts me to login and then kicks me out again.
SA> Thus, now I cannot even get to a prompt (to my knowledge).
SA> Network connectivity was not operational, ifconfig reported an error,
SA> which I cannot recall, and cannot reproduce since I can't reach the
SA> command line.

Now that I'm in morphix is getting fsck --fix-fixable /dev/hda1 my
only hope?


Thursday, April 17, 2003, 9:36:34 AM, you wrote:

JM> On Wed, Apr 16, 2003 at 05:50:21PM -0700, Sean Abrahams wrote:
>> I'm beginning to feel I should just find a new HD, create a new
>> system, and salvage what I can (Of course I don't have a daily backup).
>> The frustrating part is that I don't know how/why this all occurred.
>> Any other ideas?

JM> This has probably nothing to do with it, but have you tried checking 
JM> to make sure you have free space on the hdd (df -h) and free inodes
JM> (df -i) on the hdd.  I've seen some wacked errors resulting from both 
JM> before.

JM> Seriously though, I'd hunt down a copy of tomsrtbt or knoppix, boot 
JM> from that, fsck all the drives, do a surface scan, then defrag them.  
JM> Under tomsrtbt, it might be possible to chroot the filesystems, and 
JM> reinstall the kernel from a .deb (I've done something similiar with 
JM> lilo before, but I'm not sure if a kernel would cleanly install - but 
JM> at least you could get a list of packages to install again with dpkg:

JM>         === Backing Up With dpkg on Debian ===
JM>         Based on Info posted by Genom on Slashdot
JM>         This method allows an easy reinstall of all packages on the system.
JM>         Backing Up:
JM>                 dpkg --get-selections > selections.txt
JM>         Restoration:
JM>                 dpkg --set-selections < selections.txt
JM>                 apt-get -u dselect-upgrade

JM> Wish you luck.

Reply to: