[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: leafnode & kupdated



On Fri, Apr 26, 2002 at 11:24:38PM -0400, sda wrote:
> [ ... other issues snipped ... ]
> 
> OK, just tried this with the java package that I installed, tells me it's
> not installed, and when I try to do a 'dpkg -r j2re1.3_1.3.0-2_i386.deb
> I'm told I can't use the file name, but must use the package. Hmm seems
> like a catch 22...

"dpkg -r <package-name>", not "dpkg -r <debfile>.deb". In your case:
    # dpkg -r j2re1.3

When installing new debs, dpkg needs the filename of the *.deb.
When removing packages, dpkg only needs the package name - the bit before
the first underscore in the original .deb file name.

-- 
Karl E. Jørgensen
karl@jorgensen.com
www.karl.jorgensen.com
==== Today's fortune:
The explanation requiring the fewest assumptions is the most likely to be
correct.
		-- William of Occam

Attachment: pgplpmlcgTHjD.pgp
Description: PGP signature


Reply to: