[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrade de certaines applis ...



claude a écrit :

Stan Pinte a écrit :
[...]

Une sorte de procédure standard pour ...de knoppix basculer sur testing
par exemple... Si je dis des conneries....Arretez moi...


Ben, pour testing, ça risque d'être compliqué vu que, de base, certains paquets
sont déjà en unstable :(

Ou alors, faudrait les purger et réinstaller proprement des versions
downgradées... Suivant les besoins des uns et des autres, cela risque d'être un
peu galère quand même (surtout à cause des dépendances en chaîne) ;)

Non!!! c'est excellent. Il est indispensable qu'il existe des chemins de migration faciles pour les utilisateurs....


Ouaip, ce serait bien quand même :)

Knoppix sera utilisé par la majorité des gens qui veulent essayer linux, donc cela vaut la peine d'outiller cela sérieusement.


apt-show-versions ?

Claude


Sympa cette commande, je ne connaissais pas ...
c là k'on voit le mélange de versions de la knoppix :-p

Hum sinon j'ai installé kopete et j'ai eut le même genre de soucis que pour gaim et en fait j'ai installé le paquet à la main mais j'ai eut un problème de dépendances ensuite ... voilà comment j'ai procédé et si c une mauvaise méthode ou pas :

dpkg -i kopete_0.7.3-1_i386.deb
cd /var/cache/apt/archives/
dpkg --force-overwrite -i kdelibs-data_3.1.4-2_all.deb
dpkg --force-overwrite -i libxcursor-dev_1.0.2-2_i386.deb

d'où le résultat :

apt-cache policy kdelibs-data
kdelibs-data:
 Installés : 4:3.1.4-2
 Candidat : 4:3.1.4-2
Table de version :
    4:3.1.4-3 0
       500 http://ftp2.de.debian.org unstable/main Packages
*** 4:3.1.4-2 0
       990 http://ftp2.de.debian.org testing/main Packages
       100 /var/lib/dpkg/status

apt-cache policy libxcursor-dev
libxcursor-dev:
 Installés : 1.0.2-2
 Candidat : 1.0.2-2
Table de version :
*** 1.0.2-2 0
       990 http://ftp2.de.debian.org testing/main Packages
       500 http://ftp2.de.debian.org unstable/main Packages
       100 /var/lib/dpkg/status

apt-get -f install

je ne sais plus si c exactement cet enchainement de commandes que j'ai fait car j'ai un peu galéré pour réparer les dépendances mais j'ai fait cette manip pour mon portable sur lequel j'avais fait l'install avec "apt-get install kopete" mais en ayant fait un upgrade avant ... erf kel micmac !! enfin sur le portable kopete marche bien, tandis que sur le pc, MSN me jète en m'indiquant k'il ne peut lancer kio_http et j'ai le mem pb avec un client ftp kde tel que konqueror (il fait une erreur kio_ftp) mais bon j'ai installé puis enlevé le kdelibs-data 4:3.1.2-3 pour garder 4:3.1.2-2 au final
je fais un upgrade pour voir si ça résoud les pb de kde ?
ah lala kelle misère dès k'on veut ajouter des applis plus récentes :'(

--
Annabelle




Reply to: