[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Squeeze on Lombard

On Mit, 2011-05-04 at 15:26 -0300, Rogério Brito wrote:
> 2011/5/3 Michel Dänzer <daenzer@debian.org>:
> > Probably the radeon driver is loaded from the initrd (or even built into
> > the kernel), but the firmware is not available in the same place.
> Well, now I could make KMS work:
>     http://www.ime.usp.br/~rbrito/linux/debug-r300/2.6.39-rc6/
> I had to compile my own kernel, because just passing video=radeon to a
> regular Debian kernel doesn't supersede radeonfb, even if I make sure
> that radeon is in the initrd.

Yeah, as Gerhard pointed out, radeonfb needs to be disabled explicitly.

> * When I use any 3D application, I get distorted output, as you can
> see in the pictures in the URL above.


	Option "ColorTiling" "off"

in xorg.conf work around this? (Verify in Xorg.0.log that the option is
taking effect) 

If not, does this happen with e.g. glxgears as well?

> * When I boot with KMS, after, say, 1 minute or so (can't be precise
> here) almost all feedback from the window manager stops and I can only
> move the mouse cursor. Nothing else is updated. After some 30 seconds
> more, the monitor becomes completely dark (but the backlight is still
> on).
> Have you seen that before?

No, but it sounds like a GPU lockup.

Can you try booting with radeon.test=1 and see if the tests succeed?

Earthling Michel Dänzer           |                http://www.vmware.com
Libre software enthusiast         |          Debian, X and DRI developer

Reply to: