[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HELP!! Criticle Xserver errors

On Wed, 2004-07-14 at 04:12 -0700, Adam Done wrote:
> I have been trying to get dri working on my box and really have messed
> up the xserver.  I installed and been trying to use the dri-trunk and
> the ati driver.  See what the screen output for using dri and trunk. NOw
> I can't even start my xserver even with the fbdev driver.  

As I told you before, xserver-xfree86-dri-trunk doesn't ship the fbdev
driver. You'd have to use XFree86.nodri-trunk or uninstall xserver-
xfree86-dri-trunk to use it.

> The ati at least starts up but hangs [...]

Might be related to the DRI, try disabling it for now by commenting out
the Load "dri" line.

> #  lsmod
> Module                  Size  Used by    Not tainted
> r128                  100948   0
> mga                   106020   0  (unused)

BTW, the mga DRM is useless for you, you couldn't have loaded it in the
first place with a 2.6 kernel or the DRM built from drm-trunk-module-

> agpgart                18060   1

AGP was traditionally unstable on r128. If the X server starts up with
the DRI disabled, try not loading agpgart or Option "ForcePCIMode" in X.
If that also works, you can try a 2.6 kernel or the DRM built from drm-
trunk-module-src with AGP.

> Screen output for ati driver


> (==) Log file: "/var/log/XFree86.0.log", Time: Tue Jul 13 23:13:06 2004

Excerpts from the log file would be more useful in the future.

Earthling Michel Dänzer      |     Debian (powerpc), X and DRI developer
Libre software enthusiast    |   http://svcs.affero.net/rm.php?r=daenzer

Reply to: