[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Playing DVDs on Debian

I have been trying for the past couple of years trying to play DVDs on my Linux box and every time I run into some road blocks.  i have studied what other people have asked in the archives with a search of DVD in the subject and body and also in the users.debian lists also.  I have read and tried the many suggestions and can not figure why I  am having some issues. 

These are my recent steps I  have taken lately.

1.  according to some links I recompiled my kernel with the ide-cd module and ide-scsi as separate modules and did a

modprobe ide-scsi
modprobe sr_mod

Here is a segment of my dmesg
Probing IDE interface ide0...
hda: IC35L120AVV207-0, ATA DISK drive
hda: Enabling Ultra DMA 4
hdb: Enabling Ultra DMA 4
Probing IDE interface ide1...
hdc: Enabling MultiWord DMA 2
Probing IDE interface ide2...
ide0 at 0xf256f000-0xf256f007,0xf256f160 on irq 19
ide1 at 0xf2573000-0xf2573007,0xf2573160 on irq 20
hda: attached ide-disk driver.
hda: max request size: 1024KiB
hda: host protected area => 1
hda: 241254720 sectors (123522 MB) w/1821KiB Cache, CHS=15017/255/63, UDMA(66)
hdb: attached ide-disk driver.
hdb: host protected area => 1
hdb: 58633344 sectors (30020 MB) w/1900KiB Cache, CHS=58168/16/63, UDMA(66)
hdd: attached ide-floppy driver.
hdd: No disk in drive
hdd: 98304kB, 96/64/32 CHS, 4096 kBps, 512 sector size, 2941 rpm
hdc: attached ide-cdrom driver.
hdc: ATAPI DVD-ROM DVD-RAM drive, 2048kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices

2.  When I run gxine I get this output on the terminal

$ gxine
server: trying to connect to already running instance of gxine (/admin/root/linux/.gxine/socket)...
connect: Connection refused
server: socket '/admin/root/linux/.gxine/socket' created 
libgnomevfs.so.0: cannot open shared object file: No such file or directory.
lirc: lirc_init failed. Make sure that you have lircd running
lirc: and that you have the permissions to connect to the socket
libdvdnav: Using dvdnav version 1-rc4a from http://xine.sf.net
libdvdread: Encrypted DVD support unavailable.
libdvdnav: DVD Serial Number: 30349CC0
libdvdnav: DVD Title (Alternative): MASTER_AND_COMMANDER_D1
libdvdnav: Unable to find map file '/admin/root/linux/.dvdnav/MASTER_AND_COMMANDER_D1.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fe0000. Regions: 1
libdvdnav: Suspected RCE Region Protection!!!

[Right before the menu starts up this is outputted to the terminal and quits]

libdvdread: Invalid IFO for title 1 (VTS_01_0.IFO).
libdvdnav: ifoOpenVTSI failed - CRASHING!!!
libdvdnav: ifoRead_VTS_PTT_SRPT failed - CRASHING!!!
libdvdnav: ifoRead_PGCIT failed - CRASHING!!!
libdvdnav: ifoRead_PGCI_UT failed - CRASHING!!!
libdvdnav: ifoRead_VOBU_ADMAP vtsi failed - CRASHING
libdvdnav: ifoRead_TITLE_VOBU_ADMAP vtsi failed - CRASHING
Segmentation fault

3.  While running gxine I 

tail -f /var/log/syslog-logs/syslog

and get this response loged when gxine quits....

Jul  6 20:30:48 localhost kernel: hdc: command error: status=0x51 { DriveReady SeekComplete Error }
Jul  6 20:30:48 localhost kernel: hdc: command error: error=0x50
Jul  6 20:30:48 localhost kernel: end_request: I/O error, dev 16:00 (hdc), sector 36992

I recompiled the kernel thinking if I included 


It would take care of the SeekComplete error but it did not and still continues to output the same error.

My bane:  This has been a bane of my linux experience and very annoying to me because everyone else can get it to work but for some reason I cannot on my system.  I have been trying for the last 4 years and I  must be loosing my head by now.  Can some one help me with this... I have exhausted my knowledge and from the Internet and the mailing lists?  Thanks in advanced....


Reply to: