[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: rpath issue on 64 bit architectures



Anibal Avelar wrote:
> On 12/5/07, Leo costela Antunes <costela@debian.org> wrote:
>> <snip>
>> - And, of course, using 'chrpath' on debian/rules
>
> No, it doesn't work for AMD. I tried to use chrpath directly to
> binaries files, but it didn't work.

Are you sure? Check out package 'transmission', it's been using chrpath
for the last 3 releases (IIRC) without issues on any arch (at least
according to lintian.debian.org).
If it's being used correctly and for some reason doesn't work, please
file a bug to it (as of now it has no bugs whatsoever, giving me the
impression that it must work flawlessly).

> I had to do the option for a patch on aclocal.m4 and configure scripts
> with dpatch on build-time.
>
> On aclocal4 and configure the changes are (for each occurrence):
> -  hardcode_into_libs=yes
> +  hardcode_into_libs=no
>
> -hardcode_into_libs=$hardcode_into_libs
> +hardcode_into_libs=no

I haven't looked into your case, but unless I'm mistaken you shouldn't
need to patch aclocal.m4 if you're already patching the configure
script. You should either patch aclocal.m4 in case the configure script
will be re-generated on build-time (which is unlikely your case) or
patch the configure script directly. Or am I missing something?

BTW, it certainly seems easier to patch this option instead of patching
the '${wl}--rpath' definition, thanks for the tip!

Cheers

-- 
Leo "costela" Antunes
[insert a witty retort here]

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: