[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [MoM] Packaging fis-get

On Sat, Jan 28, 2012 at 5:13 PM, Andreas Tille <andreas@an3as.eu> wrote:
> Now I can build the "fis-gtm-initial" package
> and install it without error messages.

Cool.  I'll try it myself.  The next thing should probably be to use
some dir in /tmp or /var/tmp as TMPPOSTINST.  As far as I remember
something in /usr/lib was used - that's just wrong (and Bashkar agreed
to this opinion in one of his first mails in this thread).

My first naive attempt was to do:


but then during "debuild" I got this warning from lintian:

Now running lintian...
W: fis-gtm-initial: possibly-insecure-handling-of-tmp-files-in-maintainer-script postinst:24
Finished running lintian.

Google search pointed to:

that explains that I should have used "mktemp  --directory"
All that to say that:

MoM trainees can use a Wiki page of advice on
best practices for managing temporary directories
and files.     :-)

I checked now the policy document and the new
developers guide, but didn't see instructions on
this topic ( I may have missed thought...
my apologies if the instructions are already there.)

It took me longer that I anticipated to get it to work.
Changes have been committed to SVN.

The process involved the following stages

a) create the temp directory
b) expand the first tar.gz file that contains two
    other tar.gz files
c) then from these new two expand
    the tar.gz corresponding to the architecture
d) configure

Before, the script was doing (a,b,d), but no (c).

I'm having trouble explaining how it worked before...    :-/

but... with the new version of the postinst script
it is installing fine.

Once you get this working its time to talk to Bashkar even more
intensively how to *use* this initial package to create the real

Bhaskar was quick reply to recommend the way
to test the package so far.   (Thanks Bhaskar !)

First, we tried the command

$ /usr/lib/fis-gtm/54002B-initial/gtm

that launches GTM, and since it is the
first time it runs, it creates a directory
under $HOME/.fis-gtm

The output that we get from invoking gtm is:

%GDE-I-GDUSEDEFS, Using defaults for Global Directory

%GDE-I-EXECOM, Executing command file /usr/lib/fis-gtm/54002B-initial/gdedefaults

%GDE-I-VERIFY, Verification OK

%GDE-I-GDCREATE, Creating Global Directory file
Created file /home/ibanez/.fis-gtm/V5.4-002B_x86/g/gtm.dat
%GTM-I-JNLCREATE, Journal file /home/ibanez/.fis-gtm/V5.4-002B_x86/g/gtm.mjl created for region DEFAULT with BEFORE_IMAGES
%GTM-I-JNLSTATE, Journaling state for region DEFAULT is now ON

Bhaskar recommended to check
the version with the command:

GTM>write $zversion
GT.M V5.4-002B Linux x86

and finally quit with:


To further test, Bhaskar indicated that
when running the command a second
time it should have a cleaner output like:

$ /usr/lib/fis-gtm/54002B-initial/gtm

GTM>write $zversion
GT.M V5.4-002B Linux x86

it looks like the fis-gtm-initial package
is close to done.

Subject of course, to a more expert review
by Bhaskar, on other details that I most
certainly missed.

Since this looks good so far,
I'm now moving to make some progress
in the fis-gtm package itself.  

Starting with fixing the version from 54002A
to 54002B. I'm going back to your previous
emails, where you provided instructions on
how to do this.



Reply to: