[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ia32-libs depends on ia32-apt-get ?

Le lundi 29 juin 2009 à 15:14 +0200, Goswin von Brederlow a écrit :
> I never use aptitude and after doing a test upgrade of an older sid to
> current with aptitude I'm verry much affirmed on that. The last ~50
> packages I upgraded with "apt-get upgrade" again because the aptitude
> interface just wouldn't just do it.
> Aptitude even suggested I downgrade some package from 1.2-3 (64bit
> flavour) to 1.2-3~18 (32bit flavour) despite the later being pinned
> down. That is just horribly broken. apt-get just updated the package
> and its dependency instead.

Aptitude’s (well-known) brokenness is irrelevant. There are many other
APT frontents, like synaptic, which don’t have broken dependency
management, and which will fail just as well with ia32-apt-get.

I wonder how you could even think once that diverting apt-get was a good
idea. If you need to hook into APT to convert packages and package lists
on-the-fly, work with the APT maintainers so that APT provides hooks
usable for that effect. But DO NOT BREAK the existing APT configuration.

 .''`.      Josselin Mouette
: :' :
`. `'   “I recommend you to learn English in hope that you in
  `-     future understand things”  -- Jörg Schilling

Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=

Reply to: