[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linux-image-3.11-2-armmp_3.11.8-1_armhf not include AHCI_IMX

On Tue, Dec 17, 2013 at 09:58:17AM +0000, Ian Campbell wrote:
> On Tue, 2013-12-17 at 13:31 +0800, Niew, Sh. wrote:
> > On Dec 13, 2013, at 6:34 PM, Ian Campbell <ijc@hellion.org.uk> wrote:
> > > On Fri, 2013-12-06 at 13:54 +0800, Niew, Sh. wrote:
> > > [...]
> > >> Is it ahci_imx need ahci_platform compile with yes?
> > > 
> > > IMHO it should be loaded automatically as required. This is probably
> > > something which you need to take up with the upstream developers I'm
> > > afraid.
> > 
> > Before reaching to the upstream, i get the v3.13-rc4 a shot
> > And the issue is eliminate, but i not include every part as like the debian config included.
> So to make sure I understand what you are saying: You built upstream
> v3.13-rc4 with a config which was different to the Debian one and it
> worked fine?
> If so then either something is fixed between 3.12.3 and 3.13-rc4 or
> there is something in the config which matters. My money would be on a
> code change, but perhaps you could try with a config which is mostly the
> same as the Debian one? (i.e. start from the Debian config and run "make
> oldconfig").

FWIW: SATA is working fine for me on the wandboard quad using the 3.12.3-1~exp1
armmp kernel from experimental(thanks for that!), which is imx6q (and Niew, sh.
was talking about a sabrelite board?).

Maybe changes to the relevent dts file in 3.13* fixed it?

Maybe loading an outdated dts file at boot?

live well,

Reply to: