[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some annoying problems with ATi Radeon 7200!

Michel Dänzer wrote:
Hmm, might be caused by some cruft left over in the postinst. Cleaning
that up for the next version.

OK, I'm doing a dist-upgrade everyday, so I guess I'll see it coming then.

I downgraded the xserver-xfree86-dri-trunk package, which solved the

Ah, this might be related to the integration of RandR support. There's a
buglet which causes the server to use insane virtual resolutions,
leaving no space for textures. A workaround is to explicitly set the
virtual resolution in the display subsection. I'll look into integrating
the fix for the next version.

OK, see above. :-)

Most debug messages are gone now (e.g. when dragging the
glxgears window), but the problems with Tuxracer remain.

What problems exactly? Note that it is slow in depth 24, and it shows
some incorrect rendering unless RADEON_TCL_FORCE_DISABLE=1 is set.

This doesn't really make a difference. The problems are:
- Every about 0.4 seconds, the speed goes down dramatically for a short while (0.2 sec?), after which it continues normally. The first few seconds work normally though (I tried the Bunny Hill level) and also at the end things get slightly better.
- Tux's right arm is still a bit white and so is the bottom of his feet
- Lots of these messages on the screen: radeonUploadTexImages: ran into bound texture

I tried setting the other variable you mentioned: RADEON_NO_VTXFMT=1 solves the problem of the white arm and feet of Tux, but the game speed is even jerkier than without it.

> Really? I need to set RADEON_NO_VTXFMT=1 for the textures to be > rendered correctly.

It reallly works.

The problem may not be obvious if you don't have the skies enabled, but
you should notice the floor texture changing when you go to the menu
with Esc.

You're right. I turned on the skies and I saw the problems now. Setting that RADEON_NO_VTXFMT=1 variable helps indeed!

Definately. It seems to be a driver problem though, not a cable problem,
since I once had it working... (That was, adding the option, logging
out, restarting X with CTRL ALT BS and then logging in again...)

Not so sure, I'd expect a driver problem to be 100% reproducible.

Well, the problem is 100% reproducible! I just didn't try to reproduce the solution, since SWcursor made things worse afterall (after rebooting, at least.)

I can't seem to decode his attachment... Please e-mail that draft to me,
if you have it... Thanks in advance.


Thanks a lot! I hope the final version will be released soon, in one of the packages.

Grtjs, Manuel

PS: MSX FOR EVER! (Questions? http://faq.msxnet.org/ )
PPS: Visit my homepage at http://manuel.msxnet.org/

Reply to: