[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some annoying problems with ATi Radeon 7200!

Michel Dänzer wrote:
 > On Don, 2002-11-07 at 22:11, Manuel Bilderbeek wrote:
 >>Michel Dänzer wrote:
 > kernel-image-2.4.19-k7 also contains some DRM modules, use
 > --force-overwrite .

OK, I did it!

And, I have 3D again! :-)
Now, coming back to my previous problems (I only did a quick test

> - TuxRacer: Tux looks white!

Hah! Tux looks normal now!
However, still problems with Tuxracer: with the new drivers, the game slows down incredibly about every second. It seems to go smoooth, almost stops then, continues smoothly then, almost stops again, etc.
In my terminal this appears:
radeonUpdatePageFlipping allow 0 current 0
radeon_makeX86Normal3fv/195 CVAL 0 OFFSET 14 VAL 40763f60
radeon_makeX86Normal3fv/196 CVAL 4 OFFSET 20 VAL 40763f64
radeon_makeX86Normal3fv/197 CVAL 8 OFFSET 25 VAL 40763f68
radeon_makeX86Normal3fv done
radeonUploadTexImages: ran into bound texture
radeonUploadTexImages: ran into bound texture
radeonUploadTexImages: ran into bound texture
radeonUploadTexImages: ran into bound texture
radeonUploadTexImages: ran into bound texture
radeonUploadTexImages: ran into bound texture

If I play for a longer time, loads of those radeonUploadTexImages messages appear.... A bug? Also, in the syslog: Nov 8 20:06:57 goemon kernel: [drm:radeon_freelist_get] *ERROR* returning NULL!

> - Armagetron: when more than 3
> players are in the game, the 'motor bikes' get partly invisible;
> something goes wrong with the textures. When leaving the program, I
> can see lots of these messages from stdout/stderr:
> radeonUploadTexImages: ran into bound texture and in my syslog I get:
>  Nov 4 20:19:37 goemon kernel: [drm:radeon_freelist_get] *ERROR*
> returning NULL! Nov 4 20:20:08 goemon last message repeated 492 times

This problem is completely gone now! The game seems to work just fine!

>  - Return to Castle Wolfenstein: the program seems to work fine,
> although the framerate is quite low. However, after a short while
> things go wrong: bitmaps seem to get corrupted. E.g. the 'health
> percentage' numbers flicker and when I look at the notebook, it
> flickers and shows wrong bitmaps and such. Huge corruption. Also in
> the game menu this occurs and in the game 'world' itself, only the
> sky flickers sometimes. The fonts in general flicker too, showing
> wrong bitmaps. In other words: many, many glitches. Also here, I get
> this in the term I started the game in: radeonUploadTexImages: ran
> into bound texture

This problem is also completely gone! Yippee!

Something else that is new now: when I run e.g. glxgears and move the glxgears window, I get lots of these messages:
radeonUpdatePageFlipping allow 0 current 0

Is this normal? It's a bit annoying...

 >> > D'oh, I meant Option "SWcursor" of course. The device section is the
 >> > right place.
 >>YES! This solves the problem!
 >>So, what could be the cause of the problem and what is the disadvantage
 >>of the SWcursor? (I guess it's slower in some way...)
 > HW cursor is better for various reasons. I've never heard of such a
 > problem before. You may want to report it to the Xpert list.

I just logged in and the problem is back! And it's *massive*!! It's far
worse than I've ever seen. Any change on the screen produces this
interference now....! :-( I don't understand it at all... How could it have been solved for that particular time?
So, I commented the SWcursor out again...

I'd do anything to solve this problem. Let me know how to report to the Xpert list.

 >>I never knew this was a valid option for the Driver. Is there a list of
 >>options somewhere?
 > In the source. :) Other drivers have manpages, the radeon driver not yet
 > unfortunately. Someone posted a draft to the Xpert list a while ago,
 > would be nice if that would make it into 4.3.0 .

Where can I find that draft?

Some final questions, oh Radeon Guru! :-)
- What are safe settings for AGPSize? I saw it defaults to 8. In my BIOS I have the AGP Aperture set to 64MB, or doesn't this have to do with AGPSize? - When X is booted, the screen stays black for quite a long time. My monitor reports that the frequency is only 2Hz or so, and almost goes off. But just before it goes off, my xdm login screen appears. Is there a reason for this long delay? Can I make it shorter? - I played a bit with that AGPSize, and setting it to 64MB hung my X just after starting (xdm login screen wasn't even shown yet). Since I couldn't go back to my getty terminals (keyboard didn't respond) and xdm is autostarted at boot time, the only thing I could do was login from another computer to mine to change the XF86Config-4. Is there a smarter way to do this? :-) (By the way, I first tried both AGPSize 64 and AGPFastWrite "true", but both seem to have very negative effects on my X...

In any case: thanks a *lot* for all your help!! Keep up the good work!

Grtjs, Manuel

PS: MSX FOR EVER! (Questions? http://faq.msxnet.org/ )
PPS: Visit my homepage at http://manuel.msxnet.org/

Reply to: