[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: missing devel pkgs for emacs build

Tom Furie <tom@furie.org.uk> writes:

>> Fine is a bit strong since I am still having problems getting some of
>> the emacsclient code to compile.... but does not appear to be related
>> to xorg at all.
> It builds without trouble here. Are you building on an X system? Are you
> passing any arguments to configure? What commands are you using before
> you get to configure? 

Thanks for persisting..

One thing should be mentioned... I've allowed my debian system to fall
badly behind in updates and general maintenance.  Now face a bit of a
job getting back on track.  But doubt that is the cause of my troubles.

Yes, an X system (Lxde )

I followed the usual drill of:

sh autogen.sh (did all the reconf sort of stuff)

../configure --with-xft --with-x-toolkit=gtk 

make bootstrap (ran into the X related errors already posted.)

Took advice from here and emacs.help group 
and ran:

sudo apt-get build-dep emacs24

Went back to emacs ran ./configure the same way again

I then ran make as recorded below with tail of output. I then tried
something probably not very smart but at least not harmful and tried
building --without-kerberos....

../configure --with-xft --with-x-toolkit=gtk 
     --prefix=/usr/local/src/vcs/bzr/test --without-kerberos 

My thinking was that any of the auth related stuff might relieve emacs
of needing sasl stuff compiled and kerberos was the one I saw
mentioned in the configure flags.
And since I don't use emacs to get or send mail.  I didn't need it.

At any rate... it didn't help and ended the same as below.

-------       -------       ---=---       -------       ------- 

Tail of make command:


Adding name emacs-
make[1]: Leaving directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/src'
cd lisp && make all                          \
          CC='gcc -std=gnu99' CFLAGS='-g3 -O2' CPPFLAGS='' \
          LDFLAGS='' MAKE='make'
make[1]: Entering directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/lisp'
cd ../leim && make -w all EMACS="../src/emacs"
make[2]: Entering directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/leim'
make[2]: Leaving directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/leim'
case ../src/emacs in \
          .*) EMACS="../../src/emacs" ;; \
           *) EMACS="../src/emacs" ;; \
        esac; \
        cd ../admin/grammars && make -w all EMACS="${EMACS}"
make[2]: Entering directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/admin/grammars'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/admin/grammars'
make[2]: Entering directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/lisp'
Compiling net/sasl-cram.el

make[2]: *** [net/sasl-cram.elc] Aborted
make[2]: Leaving directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/lisp'
make[1]: *** [compile-main] Error 2
make[1]: Leaving directory `/anex/usr_local/src/vcs/bzr/emacs/trunk/lisp'
make: *** [lisp] Error 2

Reply to: